summaryrefslogtreecommitdiff
path: root/app-vim/dhcpd-syntax
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/dhcpd-syntax
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/dhcpd-syntax')
-rw-r--r--app-vim/dhcpd-syntax/Manifest4
-rw-r--r--app-vim/dhcpd-syntax/dhcpd-syntax-20030825-r1.ebuild15
-rw-r--r--app-vim/dhcpd-syntax/files/dhcpd-syntax-20030825-multiple-addresses.patch12
-rw-r--r--app-vim/dhcpd-syntax/metadata.xml13
4 files changed, 44 insertions, 0 deletions
diff --git a/app-vim/dhcpd-syntax/Manifest b/app-vim/dhcpd-syntax/Manifest
new file mode 100644
index 000000000000..51134fa806b5
--- /dev/null
+++ b/app-vim/dhcpd-syntax/Manifest
@@ -0,0 +1,4 @@
+AUX dhcpd-syntax-20030825-multiple-addresses.patch 588 BLAKE2B 1f38da00084f2e3c42ec7c851e0d4798782e7727f4677a289b0db9096d93bcd8fb2a28695c05f390727bca1c1f27ed7f4918472496e94e673009ca8ba40d9600 SHA512 9b6a22f50bb4402fbe63c7971b11a1b1d7dfec5976758897aebf14a8f0025c52daaed9e3c8668a93f5b2c7c61afde600040f6c64aeac62f2e0e9a6b01735a74a
+DIST dhcpd-syntax-20030825.tar.bz2 2761 BLAKE2B 95478de740c28a93e03179e576e2edf02a682a6161bccae676b379dbb5b654d0239c3f8e523925f2e6d36f949847f9ba7cefae20104196d71f42837afcaae76d SHA512 97c1706e0ab2c89ee20618ae0c854347f8674a3008a5c4414aacb78e984e35b0eb6eeb5f641363ed6601ceeac0c794577d518658db9200c7391871ffae5341bc
+EBUILD dhcpd-syntax-20030825-r1.ebuild 518 BLAKE2B dd2b46cc48d7053bd2d47302179cac5b1a3b5edd178209494a4fae46d06b8ba447efbf2404f66ad7ace2cfa3ce7000d60d616b47c45a53784b96073521d19256 SHA512 22eab4a129f6a32c519b1b2c71f3325bbe374506043be7bb95ea8cbce27b83968d0ad386281c0a4afc61de30d77d42305c7d00f1aa74b5f8fbcb6db2d9a9fd15
+MISC metadata.xml 451 BLAKE2B d8b36c756c321d18b52d77db7cfcd40b3ee3c9e8cdc282c090f6172f8b58b2639026650c317cbd2f4b1d575353a4b3cd22d80fbcea298d875fa5b737d69976b7 SHA512 cc138ac01df08624272da2daac14b2efd86fa8880e79b76de9fed6798fb5b8f6421fe608e2851af9c1afb7e6586f8d3f27865729960ce82ea76ac29f499e9e9a
diff --git a/app-vim/dhcpd-syntax/dhcpd-syntax-20030825-r1.ebuild b/app-vim/dhcpd-syntax/dhcpd-syntax-20030825-r1.ebuild
new file mode 100644
index 000000000000..543bd478be7a
--- /dev/null
+++ b/app-vim/dhcpd-syntax/dhcpd-syntax-20030825-r1.ebuild
@@ -0,0 +1,15 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: syntax highlighting for dhcpd.conf"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=744"
+LICENSE="vim"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd"
+
+VIM_PLUGIN_HELPTEXT="This plugin provides syntax highlighting for dhcpd.conf files."
+
+PATCHES=( "${FILESDIR}"/${P}-multiple-addresses.patch )
diff --git a/app-vim/dhcpd-syntax/files/dhcpd-syntax-20030825-multiple-addresses.patch b/app-vim/dhcpd-syntax/files/dhcpd-syntax-20030825-multiple-addresses.patch
new file mode 100644
index 000000000000..b783792d4cb1
--- /dev/null
+++ b/app-vim/dhcpd-syntax/files/dhcpd-syntax-20030825-multiple-addresses.patch
@@ -0,0 +1,12 @@
+--- a/syntax/dhcpd.vim 2005-03-24 16:41:59.755564944 +0000
++++ b/syntax/dhcpd.vim 2005-03-24 16:42:15.894111512 +0000
+@@ -33,7 +33,7 @@
+ " Base constructs {{{
+ syn match dhcpdString +"[^"]*"+
+ syn match dhcpdDecNumber "\<-\?\d\+\(;\|\s\|$\)"
+-syn match dhcpdIPv4 "\<\(\d\{1,3}\.\)\{3}\d\{1,3}\(;\|\s\|$\)"
++syn match dhcpdIPv4 "\<\(\d\{1,3}\.\)\{3}\d\{1,3}\(;\|\s\|,\|$\)"
+ syn match dhcpdMAC "\<\(\x\x\?:\)\{5}\x\x\?\(;\|\s\|$\)"
+ syn match dhcpdDate "\<[0-6]\s\d\{4}/\d\d/\d\d/\s\d\d:\d\d:\d\d\(;\|\s\|$\)"
+ """""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""" }}}
+
diff --git a/app-vim/dhcpd-syntax/metadata.xml b/app-vim/dhcpd-syntax/metadata.xml
new file mode 100644
index 000000000000..ab33f6f8c5af
--- /dev/null
+++ b/app-vim/dhcpd-syntax/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ This package provides Vim syntax highlighting for dhcpd configuration
+ files, and automatic filetype detection for these files based upon
+ filename.
+ </longdescription>
+</pkgmetadata>