summaryrefslogtreecommitdiff
path: root/app-vim/conque
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/conque
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/conque')
-rw-r--r--app-vim/conque/Manifest4
-rw-r--r--app-vim/conque/conque-2.3-r1.ebuild25
-rw-r--r--app-vim/conque/conque-2.3.ebuild22
-rw-r--r--app-vim/conque/metadata.xml11
4 files changed, 62 insertions, 0 deletions
diff --git a/app-vim/conque/Manifest b/app-vim/conque/Manifest
new file mode 100644
index 000000000000..8d79a689d211
--- /dev/null
+++ b/app-vim/conque/Manifest
@@ -0,0 +1,4 @@
+DIST conque_2.3.tar.gz 52195 BLAKE2B 31546d8e0797525cd05a4663f3598a11cbb5dd7dcc6fabf181d277e2cab88593e1458f5e646688e9e46a8d01952eb1383f358454200d59634c40920b93b7db9e SHA512 b69c0564ccaf897ee2f18d0769877986e67006cf33dbefe2bbc85261726372f09669d19aa118de58ccfb847cc8b7e670e25c030128eec665e1cecf0a96cb4b89
+EBUILD conque-2.3-r1.ebuild 679 BLAKE2B 2fe441d1398c14d2be1db505bf128f08a458d1a51e735abd5dcb5f01af41d7ae0c6524a7a98a59d54db59f712814e95a8806ef2eedd3ccedae7f24ea03341f5d SHA512 25dd890235046296654394595c91e7db6dcf91820aa44c040162942d0d621d89c796bcab6e77f1d65d4b348fac14077993b12275831b2d704c474d7e656d9f1f
+EBUILD conque-2.3.ebuild 554 BLAKE2B 64ef39e65fcd02562ef840487f3a5805971ed9c138db084cd0249d7be7ed0e33e8baae8f9b0ce4d5203bd9c6f1208786de3e63880dabb8394fa6b80f6c051c8e SHA512 c1934cab70cb7d9be06247e853ac5b32f7f131177b862639e90cfa35a2267ba7fa1773b5607bef7affc361a5f381d35e800da1dc65f4a9a6097bc40587740efc
+MISC metadata.xml 325 BLAKE2B d9e43a221c8ce8ec5a6cdfbed4c1d76cbebc9922587a1414a9bd09a14dbe1462ce2bad738ca2fa74e21686e20dc1c05a6dac2faf91abe29beb4ccc046e2014c1 SHA512 6bbcbd15af2e070d8b377cb9ce8d267b4321c895375a874d77cc85f6d9ec5aee8787415f3799b93801aa748d10a15e64968dab7ace10d9f19d48c252d2b2e4a3
diff --git a/app-vim/conque/conque-2.3-r1.ebuild b/app-vim/conque/conque-2.3-r1.ebuild
new file mode 100644
index 000000000000..93ff4281f401
--- /dev/null
+++ b/app-vim/conque/conque-2.3-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+VIM_PLUGIN_VIM_VERSION="7.1"
+
+inherit python-single-r1 vim-plugin
+
+MY_P="${PN}_${PV}"
+DESCRIPTION="vim plugin: Run interactive commands inside a Vim buffer"
+HOMEPAGE="https://code.google.com/p/conque/"
+SRC_URI="https://${PN}.googlecode.com/files/${MY_P}.tar.gz"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="|| ( app-editors/vim[python,${PYTHON_USEDEP}] app-editors/gvim[python,${PYTHON_USEDEP}] )
+ ${PYTHON_DEPS}"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+VIM_PLUGIN_HELPFILES="ConqueTerm"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/app-vim/conque/conque-2.3.ebuild b/app-vim/conque/conque-2.3.ebuild
new file mode 100644
index 000000000000..c16c2d156302
--- /dev/null
+++ b/app-vim/conque/conque-2.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4"
+VIM_PLUGIN_VIM_VERSION="7.1"
+
+inherit vim-plugin
+
+MY_P="${PN}_${PV}"
+DESCRIPTION="vim plugin: Run interactive commands inside a Vim buffer"
+HOMEPAGE="https://code.google.com/p/conque/"
+SRC_URI="https://${PN}.googlecode.com/files/${MY_P}.tar.gz"
+LICENSE="MIT"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="|| ( app-editors/vim[python] app-editors/gvim[python] )
+ >=dev-lang/python-2.3"
+
+VIM_PLUGIN_HELPFILES="ConqueTerm"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/app-vim/conque/metadata.xml b/app-vim/conque/metadata.xml
new file mode 100644
index 000000000000..6fa1407c232d
--- /dev/null
+++ b/app-vim/conque/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">conque</remote-id>
+ </upstream>
+</pkgmetadata>