summaryrefslogtreecommitdiff
path: root/app-vim/command-t
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /app-vim/command-t
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'app-vim/command-t')
-rw-r--r--app-vim/command-t/Manifest2
-rw-r--r--app-vim/command-t/command-t-5.0.3.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/app-vim/command-t/Manifest b/app-vim/command-t/Manifest
index 11bd4e9505ed..7ec25dc98fed 100644
--- a/app-vim/command-t/Manifest
+++ b/app-vim/command-t/Manifest
@@ -1,5 +1,7 @@
DIST command-t-5.0.1.tar.gz 81781 BLAKE2B 5d606892d9653c259525b6778cd72309da898fae787964fd4d1c9a6ebfd91e467e1f88f5756d7966c4866f721912164f0bf852efdd19209ce779a56725e2adbf SHA512 54262f4628bbef8a11878a8593510af566dabf35dd70005dc90e4abb4c4e9aebde5dc7d08d808c944980017f8f35d7e9723b0032ccde5ab6d2d2fae38e1c632d
DIST command-t-5.0.2.tar.gz 83601 BLAKE2B 0391f010252fcd8b48909ad4a8dd504e6cbb74f1a2f776d719a8179f0d44299bfddf8161a2961c9089cbb3a4c4c944daa4adb26927f27c4c3beebceb0b938f53 SHA512 f8c8356231c3fb0f3a91cb61f534acac4dd401721a940c6ea045ada287d29395923eb46b1cb4f55b8254000f10eea9970841531abb2b110992180a1edbd66b81
+DIST command-t-5.0.3.tar.gz 84019 BLAKE2B fec893aa698a1d1bfc86cf7bd08562f19b54e58d81b7650e50acdf17bfcec54f78aae38d05ca5f93ae60c981a6e606d5c68c008be3508c7d41e74aa9f064943a SHA512 588ee1516039e6cd45210de43307c02259fed29cc7610c222fe705cdf1d5938f51f823d41b546a36320da31db12e902363867da91b18fe56ea09c1efe2bb51fb
EBUILD command-t-5.0.1.ebuild 1274 BLAKE2B c2330d4912899a05e05f2acf5584d74342059ef6a573eb5d7fe4c9f0a64ed2225a4f0bf2d103527db7aa8f9f56cdf8339841f4e35712eb0f4f567c1744c7c5fb SHA512 4ffdedc751a9cbf8bc1a700b3220a570ff99c539e269f870f5b4a2034728243d7d261cf3c3024f0ee8d548a57c16f0745d9977be9de429896423692ea931da59
EBUILD command-t-5.0.2.ebuild 1274 BLAKE2B 26853635b32078ee63daee365599f815186565b4295ef8db749c0dd2986e6272b1554e5ee6db78b1c65432e100f0463980966e732d47ad7fcc18034f8db9b378 SHA512 a35ba097aac85835bf0d42780ac7ae87fbfbaf960e5ca1d9f60aebcf3cc42ba247e8b4d2a0a9bbf220cb1010095387c1891156a81e1ed9d1ee6777659f978380
+EBUILD command-t-5.0.3.ebuild 1271 BLAKE2B a11eee42866864fc4ed175192cd12c89c0dcd5d8cefe3f0aa7991c4d7d8d578739ef38d60978291d3148bd0c4107916185d1a0e8a1fc13725d95ad503a930b78 SHA512 747250adc16c2434e144e76604bd928f9b2b592636714e73061aebc2b8289af11bbe0f6f1c30f6365f9f2721c8c6d5f8fdf6a8a9ec1c0cec738e1e6685632793
MISC metadata.xml 331 BLAKE2B ce98227d75f9770a856398ac8ee677a237a2ebff220647964e59ffa6c02ae0162eef5a97b078014cf9c07fae2287d3bfcdba4af162f9d3760a96bc71f5cde6ae SHA512 e6b82ef13f3942afbb08a2d192073d5498640a719e64512c8203c15081e6873e0acb39421adcc711efc6a0f3adbea2953309da0d48acc86a92c51b6a3924f331
diff --git a/app-vim/command-t/command-t-5.0.3.ebuild b/app-vim/command-t/command-t-5.0.3.ebuild
new file mode 100644
index 000000000000..a8bbc97873aa
--- /dev/null
+++ b/app-vim/command-t/command-t-5.0.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+inherit vim-plugin ruby-ng
+
+DESCRIPTION="vim plugin: fast file navigation for vim"
+HOMEPAGE="https://vim.sourceforge.io/scripts/script.php?script_id=3025 https://github.com/wincent/command-t"
+SRC_URI="https://github.com/wincent/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="|| ( app-editors/vim[ruby] app-editors/gvim[ruby] )"
+
+all_ruby_prepare() {
+ find "${S}" -name .gitignore -delete || die
+}
+
+each_ruby_configure() {
+ cd ruby/${PN}/ext/${PN} || die
+ ${RUBY} extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ cd ruby/${PN}/ext/${PN} || die
+ emake V=1
+ rm *.o *.c *.h *.log extconf.rb depend Makefile || die
+}
+
+each_ruby_install() {
+ local sitelibdir=$(ruby_rbconfig_value "sitelibdir")
+ insinto "${sitelibdir}"
+ doins -r ruby/${PN}/{ext,lib}/*
+}
+
+all_ruby_install() {
+ rm Gemfile* Rakefile LICENSE README.md || die
+ rm -r appstream bin fixtures data ruby/${PN}/{ext,lib,*.gemspec} spec vendor || die
+
+ vim-plugin_src_install
+
+ # make sure scripts are executable
+ chmod +x "${ED}"/usr/share/vim/vimfiles/ruby/${PN}/bin/* || die
+}