summaryrefslogtreecommitdiff
path: root/app-vim/colorschemes/colorschemes-20140623-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/colorschemes/colorschemes-20140623-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/colorschemes/colorschemes-20140623-r1.ebuild')
-rw-r--r--app-vim/colorschemes/colorschemes-20140623-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-vim/colorschemes/colorschemes-20140623-r1.ebuild b/app-vim/colorschemes/colorschemes-20140623-r1.ebuild
new file mode 100644
index 000000000000..29f54897ed03
--- /dev/null
+++ b/app-vim/colorschemes/colorschemes-20140623-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit vim-plugin eutils
+
+DESCRIPTION="vim plugin: a collection of color schemes from vim.org"
+HOMEPAGE="https://www.vim.org/"
+
+LICENSE="vim GPL-2 GPL-2+ GPL-3 GPL-3+ MIT BSD WTFPL-2 public-domain vim.org"
+KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides a collection of color schemes for vim. To switch
+color schemes, use :colorscheme schemename (tab completion is available
+for scheme names). To automatically set a scheme at startup, please see
+:help vimrc."
+
+src_prepare() {
+ EPATCH_SOURCE="${S}/patches" \
+ EPATCH_SUFFIX="patch" \
+ EPATCH_FORCE="yes" \
+ epatch
+ rm -rf patches/
+
+ # fix line endings
+ edos2unix colors/*
+}