summaryrefslogtreecommitdiff
path: root/app-vim/c-support
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/c-support
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/c-support')
-rw-r--r--app-vim/c-support/Manifest7
-rw-r--r--app-vim/c-support/c-support-6.0.ebuild21
-rw-r--r--app-vim/c-support/c-support-6.1.1.ebuild20
-rw-r--r--app-vim/c-support/c-support-6.1.ebuild20
-rw-r--r--app-vim/c-support/metadata.xml8
5 files changed, 76 insertions, 0 deletions
diff --git a/app-vim/c-support/Manifest b/app-vim/c-support/Manifest
new file mode 100644
index 000000000000..e3ca8fdb0d13
--- /dev/null
+++ b/app-vim/c-support/Manifest
@@ -0,0 +1,7 @@
+DIST c-support-6.0.tar.bz2 130832 BLAKE2B 0cec691b367904647b2d8ea0e284027b3b7ce0d3f8db0c8e8d5c9ceac996d0cdcd2899cc4432425fd2ab0ee205069ab95a239686de81c13c77dbf7c16db06811 SHA512 280e8e91b8961ad856524f1869ecd580870ccbb6064c02aefdd5cec7f55a7bf12a17c76a4de91c8d2a7fed25bd96e793909f7cc258b9664f295e1324e0b392da
+DIST c-support-6.1.1.tar.bz2 167371 BLAKE2B 2c1d333d377eb57c52845f215c98d41e15029bd34fbef9cd8844cc2f237d129ed471d64dc71a55495189500de90b6e7fc3bb41cec18d62c51ba3b4ceb0331cc3 SHA512 dda33732505341bc260b9c3f73f95c70c3ee6f0eb50b9d1fd534fc8e83fb21d0caa3feea0ae50cf59da4abbef455c31fe1c02c80bb9168423cfa332941ff0886
+DIST c-support-6.1.tar.bz2 164255 BLAKE2B d57ab7d74eb0cc13767401aa2bad1f7883842d24e47ec0a03fb5354d5a6950029021ec1084acd7e5e86c42e9682eb4b1cc19c8c1f4c4f9d0a147571d88d51f8c SHA512 6fdc4f757ba0febfebe0c8898b6b0d582e03d6f7d08523e8663368011c41d6444df2620f96c6276d959b4a05b7c83a0e377bc5a8e75aaed5cf478f8bc83ce9ec
+EBUILD c-support-6.0.ebuild 482 BLAKE2B 3f9a451bd1c1c1e5daf2ab26c8b1d3a38d9f599d24443b730ee7a84e660dc7bd9c93375a365d0903e46ccae35d66fbc29e1e5c5b2a1d6bff975a098a20ef4919 SHA512 7950de1386b3d4dcc32aa11425f99a564e5009f9f91e2f9f3d460d50b15a4c67b8f7f5ee4268e827b62f8e31a1c31f110dac989a960279d1f9796742d3d49e9c
+EBUILD c-support-6.1.1.ebuild 472 BLAKE2B 0ae8b108eb6607233c00bb62a3a00850bad8971a0a3ff0380b08f0acbc9b54889cd3d5bd0ec8c9b142b127546ee857d6dae007b3cdfa63a906ab3e85d30b694f SHA512 34bc159b372bc8d15324b0d7a67f2eb7912410fdc19559d5075d91d6bbee5de7b8e4fd6544584fb620cd99bdfab15d02af0de9ebef29f4b2904308fc42f2fcec
+EBUILD c-support-6.1.ebuild 474 BLAKE2B e51b80a2794749007cdda1a8de58f5779b317461bd1929f8f70b577260ad4eb45e651ab5c894d47f61955f98928ebb89c584bd75e3e070d5d43fa8a33ca29066 SHA512 1c59e8308129105f946554daea9ba016667535a35bb1a115d10dbe2b8c3bd58225a2bd466622ccc95ffc489178c3f8c3969680976a9e9cd99c4ac04edea8ee42
+MISC metadata.xml 249 BLAKE2B 7ae6eac3ca23edbcbaa6aee682bb4aec155e3166f169eef8e4400e59fa56113ecc3593680d55cc57f08a4a718963dd3d0bb804bd1e8771ed60a4bebaae9db281 SHA512 4051dd059d975d2e1799125f7defbf5a62a168241d8b83d83710592efd60808800951c4fd6da1294044d7e7ec6b757b8d50593fd076696f826dec761e99645c7
diff --git a/app-vim/c-support/c-support-6.0.ebuild b/app-vim/c-support/c-support-6.0.ebuild
new file mode 100644
index 000000000000..9432efcde238
--- /dev/null
+++ b/app-vim/c-support/c-support-6.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: C/C++-IDE -- Write and run programs using menus and hotkeys"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=213"
+LICENSE="public-domain"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+src_install() {
+ dodoc ${PN}/doc/{ChangeLog,c-hotkeys.pdf}
+ rm -r ${PN}/doc || die
+
+ vim-plugin_src_install
+}
diff --git a/app-vim/c-support/c-support-6.1.1.ebuild b/app-vim/c-support/c-support-6.1.1.ebuild
new file mode 100644
index 000000000000..f9cfe8c262e4
--- /dev/null
+++ b/app-vim/c-support/c-support-6.1.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: C/C++-IDE -- Write and run programs using menus and hotkeys"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=213"
+LICENSE="public-domain"
+KEYWORDS="amd64 x86"
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+src_install() {
+ dodoc ${PN}/doc/{ChangeLog,c-hotkeys.pdf}
+ rm -r ${PN}/doc || die
+
+ vim-plugin_src_install
+}
diff --git a/app-vim/c-support/c-support-6.1.ebuild b/app-vim/c-support/c-support-6.1.ebuild
new file mode 100644
index 000000000000..b845e2e7abfc
--- /dev/null
+++ b/app-vim/c-support/c-support-6.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: C/C++-IDE -- Write and run programs using menus and hotkeys"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=213"
+LICENSE="public-domain"
+KEYWORDS="amd64 x86"
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+src_install() {
+ dodoc ${PN}/doc/{ChangeLog,c-hotkeys.pdf}
+ rm -r ${PN}/doc || die
+
+ vim-plugin_src_install
+}
diff --git a/app-vim/c-support/metadata.xml b/app-vim/c-support/metadata.xml
new file mode 100644
index 000000000000..5c000c763084
--- /dev/null
+++ b/app-vim/c-support/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+</pkgmetadata>