summaryrefslogtreecommitdiff
path: root/app-vim/breakpts
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-07 11:03:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-07 11:03:14 +0100
commit957235cf19a691360c720f7913672adda4258ed0 (patch)
tree812bba7928f4293ead05a7ee9c1ac39c5ef9f12e /app-vim/breakpts
parent62f67115b5c46134c34f88f4b1cbdacc19384c0a (diff)
gentoo resync : 07.10.2018
Diffstat (limited to 'app-vim/breakpts')
-rw-r--r--app-vim/breakpts/Manifest2
-rw-r--r--app-vim/breakpts/breakpts-4.0-r2.ebuild27
2 files changed, 29 insertions, 0 deletions
diff --git a/app-vim/breakpts/Manifest b/app-vim/breakpts/Manifest
index 1e2df12aa0e4..d4fd65c86051 100644
--- a/app-vim/breakpts/Manifest
+++ b/app-vim/breakpts/Manifest
@@ -1,3 +1,5 @@
DIST breakpts-4.0.tar.bz2 17349 BLAKE2B c7ad9eed8fb13537c940e6868f5e4e5dd812a6b7f7c26c4617e3c24905b6e2a817dc91990b613b700e793dd763a6841f85dd7f9cc42fb9f5afc25c3609f909fc SHA512 a480bf32cd3e756ac25849b1d5fd20521bd8c965454bb94c33810c9d1d4464762a731d08dcae858c59853a6cf41ab3cb6cddeda440c8b041cc8ec192ab2bd2fd
+DIST breakpts-4.0.zip 20124 BLAKE2B 2ea7568af5407d57c4d4b505c69d625056d62e8f5bd25bf5ca13918e3ffbc0f83de2aedb0abc3468215a650308ed8b592a618c0b50c24dd8ad3f931ef5d2ff8b SHA512 3e7f148896a10abd30a16d903c14460668ee48d078ae3c3b6ff663dab53d32199d8cf9cd3a56164a32d0be2684e64a882e917f3f632318ce85db5eb07e29754d
EBUILD breakpts-4.0-r1.ebuild 682 BLAKE2B bf0c5025e3e2707a805b6fbd22f97313235c6a7d55f0397015c36f7e0041305c374fc44104d5a26c1f56f9a7452b60fa26f72869d6fb65b1f433e9f90930780a SHA512 90aed4c69a96cf1cbbd27162d9e1b057792f3f1ccaf6335a99060bbf89fe2b1dfb0344c2999004802628329b567ff33728faf643df0cfc5eabd73ece79a1c250
+EBUILD breakpts-4.0-r2.ebuild 803 BLAKE2B 1ac75b05bd5d45dbcdc8cedb9687769c1deff041acd406824b62e40758c57927e95c031533d15a353a59a436d45f2cb3ca1519fb37c1dfdfcc6e27abb3d4d2e8 SHA512 eaf5a8afbd71843625a60c672bacc09b3e1d52d6ba6a69e0878ad48d0dd9fe1000ee67619b9cc0e5981fa80fd676e9ad0f62563bda5901eb9b97d2a09fbac701
MISC metadata.xml 249 BLAKE2B 7ae6eac3ca23edbcbaa6aee682bb4aec155e3166f169eef8e4400e59fa56113ecc3593680d55cc57f08a4a718963dd3d0bb804bd1e8771ed60a4bebaae9db281 SHA512 4051dd059d975d2e1799125f7defbf5a62a168241d8b83d83710592efd60808800951c4fd6da1294044d7e7ec6b757b8d50593fd076696f826dec761e99645c7
diff --git a/app-vim/breakpts/breakpts-4.0-r2.ebuild b/app-vim/breakpts/breakpts-4.0-r2.ebuild
new file mode 100644
index 000000000000..1dcdff18bc43
--- /dev/null
+++ b/app-vim/breakpts/breakpts-4.0-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: sets vim breakpoints visually"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=618"
+SRC_URI="https://www.vim.org/scripts/download_script.php?src_id=8142 -> ${P}.zip"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+
+S="${WORKDIR}"
+
+RDEPEND="
+ || ( >=app-editors/vim-7.0 >=app-editors/gvim-7.0 )
+ >=app-vim/multvals-3.6.1
+ >=app-vim/genutils-1.13
+ >=app-vim/foldutil-1.6"
+DEPEND="app-arch/unzip"
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin allows breakpoints to be set and cleared visually. To start,
+use :BreakPts, move to the required function and press <CR>. Breakpoints
+can then be added using :BPToggle or <F9>."