summaryrefslogtreecommitdiff
path: root/app-vim/breakpts/breakpts-4.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/breakpts/breakpts-4.0-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/breakpts/breakpts-4.0-r1.ebuild')
-rw-r--r--app-vim/breakpts/breakpts-4.0-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-vim/breakpts/breakpts-4.0-r1.ebuild b/app-vim/breakpts/breakpts-4.0-r1.ebuild
new file mode 100644
index 000000000000..2358b0b21ccd
--- /dev/null
+++ b/app-vim/breakpts/breakpts-4.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: sets vim breakpoints visually"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=618"
+LICENSE="GPL-2"
+KEYWORDS="alpha amd64 ia64 ~mips ppc sparc x86"
+IUSE=""
+
+RDEPEND="
+ || ( >=app-editors/vim-7.0 >=app-editors/gvim-7.0 )
+ >=app-vim/multvals-3.6.1
+ >=app-vim/genutils-1.13
+ >=app-vim/foldutil-1.6"
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin allows breakpoints to be set and cleared visually. To start,
+use :BreakPts, move to the required function and press <CR>. Breakpoints
+can then be added using :BPToggle or <F9>."