summaryrefslogtreecommitdiff
path: root/app-vim/airline
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /app-vim/airline
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'app-vim/airline')
-rw-r--r--app-vim/airline/Manifest4
-rw-r--r--app-vim/airline/airline-0.10.ebuild29
-rw-r--r--app-vim/airline/airline-9999.ebuild4
3 files changed, 34 insertions, 3 deletions
diff --git a/app-vim/airline/Manifest b/app-vim/airline/Manifest
index f6ea693ad700..8a08fadb0d5d 100644
--- a/app-vim/airline/Manifest
+++ b/app-vim/airline/Manifest
@@ -1,4 +1,6 @@
+DIST airline-0.10.tar.gz 86724 BLAKE2B b0019b07b188039a9a91d83bc240e6b2eedaf9d798483f03d252b57269c0cbbc58625b3d14e36a3caaa6fd35b65716d67a967a38511806d76bc7e76192086349 SHA512 94c87800b793d575d8e1fbf2971cc97e89aae4a6bd9581aee628d4e4f2d9e74df427fcc91b17908819b5f4793c72a9d0a827d5046d80918a52ef8e090ff2cae6
DIST airline-0.9.tar.gz 72660 BLAKE2B d6c9762d8140b2a88a001b9ea3ae62c3c9147ccf3db90146d7fded8dcbc6062bf97c0725baa79db9d7bfe0eeaa5dc00ddfabde8ed1b9aec7f5aa24c41b11d1f2 SHA512 f3fd03c7ab6603eee6e892a1b88888d72fc43cf0a8582ad7e65152cddebb0d14be3a805529fa5467fc82e040cce2616f1693bf294c892c0849d9fb51cbbd04ec
+EBUILD airline-0.10.ebuild 758 BLAKE2B 6f9b9121a4d19c6c559a9f4a3ea618a6cb832bfd3a6700bf903f5bd25dc9b692a9ceeaefdf083dffc39c2523e2dd8cf6d03f1430ab924fe4114ae9392649d791 SHA512 bec80c27f7e2a9607fbe0d1c9421949bc202c795de731c840652181426a32d07c2b23073e7933ad053ea644eda2d4af2dd840aa4e6f0e79b0a7df30226f4bfec
EBUILD airline-0.9.ebuild 759 BLAKE2B 436c701d3158c3905c2b00c9af14cb27637f15b54d8f4f5fb042136331581547241e74ab2c8fc8f9f782124ea4e7bc0a87186da0f7d544e5ae183cbdc3ece437 SHA512 4ea077bbe732cde3af20eab05373aca10696525de22e741140082c520d16c82d17c64c702dd62c8435a13de95436143c601f46220713b48a2cc5bfeb12afea8c
-EBUILD airline-9999.ebuild 761 BLAKE2B 8765adadb622edda9254aa516563a3230f1088a811a610ce6d9571092cfb3b29c5f2b082ea3adba859b6685a29a0b8c93c52618ba1d8a0ddd21534ae587c8afe SHA512 f3cc5f2451af1779c231ce82d955ac6a44fad7d5819e305353d1f1f8f2094207b3e2c6b0a7f6cf7403eac9456761151b414acb74967848e9bb02e9920ce621da
+EBUILD airline-9999.ebuild 758 BLAKE2B 6f9b9121a4d19c6c559a9f4a3ea618a6cb832bfd3a6700bf903f5bd25dc9b692a9ceeaefdf083dffc39c2523e2dd8cf6d03f1430ab924fe4114ae9392649d791 SHA512 bec80c27f7e2a9607fbe0d1c9421949bc202c795de731c840652181426a32d07c2b23073e7933ad053ea644eda2d4af2dd840aa4e6f0e79b0a7df30226f4bfec
MISC metadata.xml 341 BLAKE2B 773326b7103bbac0a5d028d4269187e8acd4a7c0603cb1ccdb129c2d3cffed385e87f47fadd5fd8d68dcf5271521ccddc43412b7f8b7ab41dd7618c65f56c849 SHA512 90eec982571c778fff57d1e8a604fd994d249149846544223c2cb0c244c16632fb320fce1eda35641bc0a914cc2a9031bd2e73a1444412119690a2d3729c541a
diff --git a/app-vim/airline/airline-0.10.ebuild b/app-vim/airline/airline-0.10.ebuild
new file mode 100644
index 000000000000..5c0506370c59
--- /dev/null
+++ b/app-vim/airline/airline-0.10.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+if [[ ${PV} != 9999* ]] ; then
+ MY_PN=vim-${PN}
+ MY_P=${MY_PN}-${PV}
+ SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S=${WORKDIR}/${MY_P}
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vim-airline/vim-airline.git"
+fi
+
+DESCRIPTION="vim plugin: lean & mean statusline for vim that's light as air"
+HOMEPAGE="https://github.com/vim-airline/vim-airline/ https://www.vim.org/scripts/script.php?script_id=4661"
+LICENSE="MIT"
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ default
+
+ # remove unwanted files
+ rm -r t Gemfile Rakefile LICENSE README* || die
+}
diff --git a/app-vim/airline/airline-9999.ebuild b/app-vim/airline/airline-9999.ebuild
index 2b0d045e241b..5c0506370c59 100644
--- a/app-vim/airline/airline-9999.ebuild
+++ b/app-vim/airline/airline-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit vim-plugin