summaryrefslogtreecommitdiff
path: root/app-vim/airline
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-25 19:22:13 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-03-25 19:22:13 +0100
commit6bd95d1f6320b8666a31ec949183aaa3088aa16f (patch)
treeff9f0cde8bfba5191f96c690c269c814c134a51e /app-vim/airline
parentb279bbe94522565b8feb19b8e5f377d3ea76f157 (diff)
gentoo resync : 25.03.2018
Diffstat (limited to 'app-vim/airline')
-rw-r--r--app-vim/airline/Manifest4
-rw-r--r--app-vim/airline/airline-0.9.ebuild29
-rw-r--r--app-vim/airline/airline-9999.ebuild3
3 files changed, 34 insertions, 2 deletions
diff --git a/app-vim/airline/Manifest b/app-vim/airline/Manifest
index 06462fcd2228..9910c89e4d3f 100644
--- a/app-vim/airline/Manifest
+++ b/app-vim/airline/Manifest
@@ -1,4 +1,6 @@
DIST airline-0.8.tar.gz 52767 BLAKE2B 908489fca1fb31d0ee41f279b146046d50c9069055bb13645b049c4333984f0ca180315e50fe3fda13e36780dffa0b213719babbbcd2b27defd60470a05dbc2f SHA512 51ae20f7e5b869f714e9c21ab6ab8af4d2de31b3cf4fe9f6bd64e75e87e7796184d41ddd9536f3e41dcc93e9ca6aad684b286df6e5d8d6eae202f91ed8851292
+DIST airline-0.9.tar.gz 72660 BLAKE2B d6c9762d8140b2a88a001b9ea3ae62c3c9147ccf3db90146d7fded8dcbc6062bf97c0725baa79db9d7bfe0eeaa5dc00ddfabde8ed1b9aec7f5aa24c41b11d1f2 SHA512 f3fd03c7ab6603eee6e892a1b88888d72fc43cf0a8582ad7e65152cddebb0d14be3a805529fa5467fc82e040cce2616f1693bf294c892c0849d9fb51cbbd04ec
EBUILD airline-0.8.ebuild 751 BLAKE2B 8be15c3264b648a0b319e9d716d98bb8cab064c50afcc7b13262b59fb620ae9421df11a6ab096e506f9aad84d95c7a79bcf12d6ae4d412137c2afc75e62dbc71 SHA512 b394b5a818dfb48ef8564b30b4c16bd6fa786f0975bb7bd5a3c8698d8f3138dc18191c78cc3e2f0581154927d8aafdb3ba7381f7c02f70eaf0e6df0543ed5ce9
-EBUILD airline-9999.ebuild 750 BLAKE2B 620145a57cca1495b5b7684adcb2f44ea61fad984d6a13e8514a77eb726c412c3069b1dd1c945d471f0ec80c4ca7d95fadd57f6db66d205978d6950cb0334e6c SHA512 be985fceda4bfb738887e6139fb4d21a984ef21959080566f4d269efa8602271e9dd96eec6e29fdbbb64837bf641610efb9a766d3afaba8816a406e9eeddc9ea
+EBUILD airline-0.9.ebuild 761 BLAKE2B 8765adadb622edda9254aa516563a3230f1088a811a610ce6d9571092cfb3b29c5f2b082ea3adba859b6685a29a0b8c93c52618ba1d8a0ddd21534ae587c8afe SHA512 f3cc5f2451af1779c231ce82d955ac6a44fad7d5819e305353d1f1f8f2094207b3e2c6b0a7f6cf7403eac9456761151b414acb74967848e9bb02e9920ce621da
+EBUILD airline-9999.ebuild 751 BLAKE2B 89604ccbf2b4938134a3b7174355ef8e553b1454659d5e368d6d8fb1c57d67ba4982c5bae2e94a2b89652039bb86f6deb6b5e6be754675f277c67760b611e254 SHA512 9d8dcdd96b4e739fbe0ee3b1400017110d3a5f3d69e29e4780228461f335e326931b6eae2656d3cd933ad9dd89012c02eabbf3cbfded6d6df3a866e319b680bc
MISC metadata.xml 341 BLAKE2B 773326b7103bbac0a5d028d4269187e8acd4a7c0603cb1ccdb129c2d3cffed385e87f47fadd5fd8d68dcf5271521ccddc43412b7f8b7ab41dd7618c65f56c849 SHA512 90eec982571c778fff57d1e8a604fd994d249149846544223c2cb0c244c16632fb320fce1eda35641bc0a914cc2a9031bd2e73a1444412119690a2d3729c541a
diff --git a/app-vim/airline/airline-0.9.ebuild b/app-vim/airline/airline-0.9.ebuild
new file mode 100644
index 000000000000..2b0d045e241b
--- /dev/null
+++ b/app-vim/airline/airline-0.9.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+if [[ ${PV} != 9999* ]] ; then
+ MY_PN=vim-${PN}
+ MY_P=${MY_PN}-${PV}
+ SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S=${WORKDIR}/${MY_P}
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vim-airline/vim-airline.git"
+fi
+
+DESCRIPTION="vim plugin: lean & mean statusline for vim that's light as air"
+HOMEPAGE="https://github.com/vim-airline/vim-airline/ https://www.vim.org/scripts/script.php?script_id=4661"
+LICENSE="MIT"
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ default
+
+ # remove unwanted files
+ rm -r t Gemfile Rakefile LICENSE README* || die
+}
diff --git a/app-vim/airline/airline-9999.ebuild b/app-vim/airline/airline-9999.ebuild
index 248f1fbb3ed7..8f8c09743034 100644
--- a/app-vim/airline/airline-9999.ebuild
+++ b/app-vim/airline/airline-9999.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
+
inherit vim-plugin
if [[ ${PV} != 9999* ]] ; then