summaryrefslogtreecommitdiff
path: root/app-vim/airline
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-vim/airline
reinit the tree, so we can have metadata
Diffstat (limited to 'app-vim/airline')
-rw-r--r--app-vim/airline/Manifest6
-rw-r--r--app-vim/airline/airline-0.8.ebuild27
-rw-r--r--app-vim/airline/airline-9999.ebuild26
-rw-r--r--app-vim/airline/metadata.xml11
4 files changed, 70 insertions, 0 deletions
diff --git a/app-vim/airline/Manifest b/app-vim/airline/Manifest
new file mode 100644
index 000000000000..5706bf8d2386
--- /dev/null
+++ b/app-vim/airline/Manifest
@@ -0,0 +1,6 @@
+DIST airline-0.8.tar.gz 52767 SHA256 5fb1cdcd9a760516a050bd0e3fa4cae04291cfccd2bcf58f2facbd2a07767a14 SHA512 51ae20f7e5b869f714e9c21ab6ab8af4d2de31b3cf4fe9f6bd64e75e87e7796184d41ddd9536f3e41dcc93e9ca6aad684b286df6e5d8d6eae202f91ed8851292 WHIRLPOOL a5ccf7662267c25b6855d6df81c4c3f35bffe5c2001f05808c1e0a861bb6b04b0bc04d979b04a060992626406cd84d7ac8aabd73f29afaf286fbf4dbc3dec47c
+EBUILD airline-0.8.ebuild 750 SHA256 bf7a94e0b7471ebceb2d57b308af67b58b57e4ffaf37adb9b7b9fe4ac94be64d SHA512 4cef4ca504e0eb4e028a20011ee5dc3b1a1b4989efed4343e4ed2ee0dae14d8c7d9541cc8835124601e64d9ff3c826bc4b6e9520b894baa04cbfd768d6726af6 WHIRLPOOL fdc15fc122db67102141ac839595077e0f40491c9f2492f0b18296db9e854994dc6a947e48defd264eaa8bc98b05ead91138f11fdb8797c1754172d21ba56a22
+EBUILD airline-9999.ebuild 749 SHA256 ced9a6dbeaa19b59e79614ae40873099da64f657309f0408b39c0f84b9550dee SHA512 a9fb9cd9f871836d400f1b63d7a901f5668f75d1e18a7dd89de5e86761d496e051f438575998e2a2597f5fc00a52f9cfe6cbac6545d9735f9ec3ffef95e19cea WHIRLPOOL 7c994619fb8ac8f7c578383db22c44768c336364b0498245473a75e526c57eae266c18fd74ea9e6dc3183498f02b6ac99303cdb35fa27fea023ad68e78345786
+MISC ChangeLog 3476 SHA256 e57871063444d64ef773b4673f0e17cce77fc9755ba20ce5f58936e665901e3e SHA512 cb4439702283d7124333f502d8203a0443b2f7593ed0b130152b33a12c3f68204a383ed2fc71202f217c0dc6131f3f308bf3c462c5bd8f88bfaf95afbfe2b703 WHIRLPOOL b037df07edfd2d3c4a1b52abfb6be8981f49e81b2a24c03fb188e6f52229065299d5978e0e8576e1ce68df78fdd04d7e3e93e80b0358a359e16aa0e71ea01f34
+MISC ChangeLog-2015 990 SHA256 976dbc3536d228c32ca0b9fcd8f4ba67d19529254482ebdb70ded1a193d4eb78 SHA512 5df94b0f00689b0d03e35a878e4f5379f1135695ed461f91432dbdd425180bc169806b21d7a850877f5abf88f0e2de04bd23254cda14cc6e222dd71efbcf4c16 WHIRLPOOL cde2967222e778e7edf2b3a362ec2abbb0cdb2f09a1d527dcddc53a74f48899c2b8736f279274f52f7477a28532ff44140cfcb711b235d1b59d41766e778ad65
+MISC metadata.xml 341 SHA256 e6e6695adbf23867ef394e9b424c9a6fbd500731a36711787f8a36c6454d7dad SHA512 90eec982571c778fff57d1e8a604fd994d249149846544223c2cb0c244c16632fb320fce1eda35641bc0a914cc2a9031bd2e73a1444412119690a2d3729c541a WHIRLPOOL 922984f26d0325f153d805e5c511d3c0cb733a771df1479dfc5baf13562e4756168eb46b11927b0e8fc70b2c199fe4599df5179e8b12ee6c67e0c10f6aba1fd7
diff --git a/app-vim/airline/airline-0.8.ebuild b/app-vim/airline/airline-0.8.ebuild
new file mode 100644
index 000000000000..8959016c24a0
--- /dev/null
+++ b/app-vim/airline/airline-0.8.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit vim-plugin
+
+if [[ ${PV} != 9999* ]] ; then
+ MY_PN=vim-${PN}
+ MY_P=${MY_PN}-${PV}
+ SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 x86"
+ S="${WORKDIR}/${MY_P}"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vim-airline/vim-airline.git"
+fi
+
+DESCRIPTION="vim plugin: lean & mean statusline for vim that's light as air"
+HOMEPAGE="https://github.com/vim-airline/vim-airline/ http://www.vim.org/scripts/script.php?script_id=4661"
+LICENSE="MIT"
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ # remove unwanted files
+ rm -r t Gemfile Rakefile LICENSE README* || die
+}
diff --git a/app-vim/airline/airline-9999.ebuild b/app-vim/airline/airline-9999.ebuild
new file mode 100644
index 000000000000..82c71b13e2ec
--- /dev/null
+++ b/app-vim/airline/airline-9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit vim-plugin
+
+if [[ ${PV} != 9999* ]] ; then
+ MY_PN=vim-${PN}
+ MY_P=${MY_PN}-${PV}
+ SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S=${WORKDIR}/${MY_P}
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vim-airline/vim-airline.git"
+fi
+
+DESCRIPTION="vim plugin: lean & mean statusline for vim that's light as air"
+HOMEPAGE="https://github.com/vim-airline/vim-airline/ http://www.vim.org/scripts/script.php?script_id=4661"
+LICENSE="MIT"
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ # remove unwanted files
+ rm -r t Gemfile Rakefile LICENSE README* || die
+}
diff --git a/app-vim/airline/metadata.xml b/app-vim/airline/metadata.xml
new file mode 100644
index 000000000000..9135445654a8
--- /dev/null
+++ b/app-vim/airline/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">bling/vim-airline</remote-id>
+ </upstream>
+</pkgmetadata>