summaryrefslogtreecommitdiff
path: root/app-text
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-20 03:02:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-20 03:02:59 +0000
commit8a5f3383bbc5f817d89554020a3600d06985bc4a (patch)
treec1f7e85e7de87c74b4c730fab5369051cef5cb32 /app-text
parentf2e359c456b051f95efc92e21299d55a302e58ed (diff)
gentoo auto-resync : 20:11:2024 - 03:02:59
Diffstat (limited to 'app-text')
-rw-r--r--app-text/Manifest.gzbin50320 -> 50326 bytes
-rw-r--r--app-text/unrtf/Manifest2
-rw-r--r--app-text/unrtf/files/unrtf-0.21.10-use-_GNU_SOURCE.patch11
-rw-r--r--app-text/unrtf/unrtf-0.21.10-r1.ebuild24
4 files changed, 37 insertions, 0 deletions
diff --git a/app-text/Manifest.gz b/app-text/Manifest.gz
index ce057ed5472a..5c369d4b05b3 100644
--- a/app-text/Manifest.gz
+++ b/app-text/Manifest.gz
Binary files differ
diff --git a/app-text/unrtf/Manifest b/app-text/unrtf/Manifest
index f20be6657bc6..ced44c18f08b 100644
--- a/app-text/unrtf/Manifest
+++ b/app-text/unrtf/Manifest
@@ -1,3 +1,5 @@
+AUX unrtf-0.21.10-use-_GNU_SOURCE.patch 213 BLAKE2B 068d2417a1d35ce8bf3f69850d0ca33bd7ba419dca2c62dd4a1ee4c2f07713bd83824fd485d1189058cc5b2abc3e5ddb2ee630a006f026e957f14e6cb185d29b SHA512 1d104dafd1734de971db8751609eea1d574505adc55a3b931ae882ae69c58cede61dd504a7cd5e69948197cf79aa1716e44cc068c2e7d120bda19a2b5a045aba
DIST unrtf-0.21.10.tar.gz 812696 BLAKE2B 3edc654feee461bb785877c3c3829462b9f55556e352bd12a19e426911336e161431badf5fdf5e00b0c488ca1804a0922ac7eb6980ebec58232112f6cf156f34 SHA512 31bedd1a23a052c1235e1328a12b346a0fe48b3f3cf78d72c068fe0d3edf18bc78f4c9dfe2f093ee8b4f3c79e923c6ceda49bc257d191dd5371f9273809343c9
+EBUILD unrtf-0.21.10-r1.ebuild 557 BLAKE2B 54a36da8a15e9a96779728706c3869620f9688d6571d1da129a5dba63416b982f7ae7d07968673d72e9f64bc4233efde1349b633e8c81386dbcc81193cd3a8c1 SHA512 6af3de1ccece425bb6acc8428e461916958c12fba1aec43ff3106c3ed67b3d942e2978d307320f33dec3b46bb5a6a39bc4d076c1b9f69f66f089d8b2e4b30897
EBUILD unrtf-0.21.10.ebuild 419 BLAKE2B c399340c8f4f94aec89255331a63c3d83e8259701560c08ce68f186edfdcef9e6b9b7ed69bb8bbcb81cf8773d160ffdcda16d28c4931d020608b57111294105d SHA512 c7afd75fff24f0dc2e61168b38b2ce2ed5172663fc711173411c3cfa9dd44a5d078477bb318df4d651ba2707f2f7c03bc258664891d6bb7af5d9eec35c67aeb0
MISC metadata.xml 299 BLAKE2B 492d0e3ba9bff1a327d49c13d54bce9fadbd690ce4ebd5f62b283545b098f553d93cb1938c0c66da695f06775e6a035e87d70c01dd04985cd9e850d360ec377c SHA512 b4d3519e2e55716235643397e55b101a80808ed1cb82f2618f0779551d0d6e5ed8abffd65e2203c64d604f23d23575c0f93bd2c897cb3e29ff0ed73c32d30ca9
diff --git a/app-text/unrtf/files/unrtf-0.21.10-use-_GNU_SOURCE.patch b/app-text/unrtf/files/unrtf-0.21.10-use-_GNU_SOURCE.patch
new file mode 100644
index 000000000000..7aaaef65e27a
--- /dev/null
+++ b/app-text/unrtf/files/unrtf-0.21.10-use-_GNU_SOURCE.patch
@@ -0,0 +1,11 @@
+Bug: https://bugs.gentoo.org/894716
+--- a/src/convert.c
++++ b/src/convert.c
+@@ -104,6 +104,7 @@
+ #ifdef HAVE_STRING_H
+ /* For strcasestr() */
+ #define __USE_GNU
++#define _GNU_SOURCE
+ #include <string.h>
+ #endif
+
diff --git a/app-text/unrtf/unrtf-0.21.10-r1.ebuild b/app-text/unrtf/unrtf-0.21.10-r1.ebuild
new file mode 100644
index 000000000000..23f0d5e21681
--- /dev/null
+++ b/app-text/unrtf/unrtf-0.21.10-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="Converts RTF files to various formats"
+HOMEPAGE="https://www.gnu.org/software/unrtf/unrtf.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-solaris"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.21.10-use-_GNU_SOURCE.patch
+)
+
+src_configure() {
+ append-flags -std=gnu17
+
+ econf
+}