summaryrefslogtreecommitdiff
path: root/app-text/zotero-bin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /app-text/zotero-bin
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'app-text/zotero-bin')
-rw-r--r--app-text/zotero-bin/Manifest3
-rw-r--r--app-text/zotero-bin/metadata.xml12
-rw-r--r--app-text/zotero-bin/zotero-bin-5.0.96.2.ebuild72
3 files changed, 87 insertions, 0 deletions
diff --git a/app-text/zotero-bin/Manifest b/app-text/zotero-bin/Manifest
new file mode 100644
index 000000000000..59dbb8b837ac
--- /dev/null
+++ b/app-text/zotero-bin/Manifest
@@ -0,0 +1,3 @@
+DIST zotero-bin-5.0.96.2.tar.bz2 60475436 BLAKE2B 2c113fbbb78f0e4ca4e12ed31ed43ba6e65eea88039f9fda1d1f97e6407b95e9ac1d89b2504f220ce96634f5404defcdb5f5346dec83d5d9f02832e1573f1a60 SHA512 4fc988bf74179ad5f28a4649cfc6c6c5d4eeabc3b7aa60e717681bc57dd1c3ba6f2d3310fb83e6e2e55475aa9d7077329acc3dff52b63a0759c32f542ef0ef47
+EBUILD zotero-bin-5.0.96.2.ebuild 1743 BLAKE2B 1fae784ad08e72c0f56b300c2ac57dc70cd87dfc8c022245c6b8387132eec4d9674d298ef85aceb747375aa8963ca19941d23dd9227643085770280e3cb661fa SHA512 8d417609a9e251ef49bd220700bb7f04a941b39e9662d659370ae2d876d33d404046d889b41242de161754a7f0f40702c11d00995f5d9b1ee697afd3b0908529
+MISC metadata.xml 397 BLAKE2B f48e28fccd0f77504f72fa58caccaf122774c308ec6367d76f11706dced05efd74e7075dbdb8dc9689db9555a471b0ed15a904fda9556014d35448eccacb31d7 SHA512 38ccb96f65b58cf9b992fa89d89fbf10bd94f9331a268aafc374332bd02ed136539627754fe807e875c4e2fd4e1a42db4f6f3e937f203c2c1a0c1e03a884b156
diff --git a/app-text/zotero-bin/metadata.xml b/app-text/zotero-bin/metadata.xml
new file mode 100644
index 000000000000..dc1be65adf8e
--- /dev/null
+++ b/app-text/zotero-bin/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">zotero/zotero</remote-id>
+ <bugs-to>https://github.com/zotero/zotero/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/zotero-bin/zotero-bin-5.0.96.2.ebuild b/app-text/zotero-bin/zotero-bin-5.0.96.2.ebuild
new file mode 100644
index 000000000000..a6626cdb8945
--- /dev/null
+++ b/app-text/zotero-bin/zotero-bin-5.0.96.2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop xdg
+
+DESCRIPTION="Helps you collect, organize, cite, and share your research sources"
+HOMEPAGE="https://www.zotero.org"
+SRC_URI="https://www.zotero.org/download/client/dl?channel=release&platform=linux-x86_64&version=${PV} -> ${P}.tar.bz2"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+RDEPEND="
+ dev-libs/atk
+ dev-libs/dbus-glib
+ dev-libs/glib
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/fontconfig
+ media-libs/freetype
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrender
+ x11-libs/libXt
+ x11-libs/pango
+"
+
+S="${WORKDIR}/Zotero_linux-x86_64"
+
+QA_PREBUILT="/opt/zotero/*"
+
+src_prepare() {
+ # disable auto-update
+ sed -i -e 's/\(pref("app.update.enabled"\).*/\1, false);/' defaults/preferences/prefs.js || die
+
+ # disable default oo installation questions - manual installation is still possible
+ sed -i -e 's/\(pref("extensions.zoteroOpenOfficeIntegration.skipInstallation"\).*/\1, true);/' \
+ extensions/zoteroOpenOfficeIntegration@zotero.org/defaults/preferences/zoteroOpenOfficeIntegration.js || die
+
+ # fix desktop-file
+ sed -i -e 's#^Exec=.*#Exec=zotero#' zotero.desktop
+ sed -i -e 's#Icon=zotero.*#Icon=zotero#' zotero.desktop
+
+ default
+}
+
+src_install() {
+ dodir opt/zotero
+ cp -a "${S}"/* "${ED}/opt/zotero" || die
+
+ dosym ../../opt/zotero/zotero usr/bin/zotero
+
+ domenu zotero.desktop
+
+ for size in 16 32 48 256; do
+ newicon -s ${size} chrome/icons/default/default${size}.png zotero.png
+ done
+}