summaryrefslogtreecommitdiff
path: root/app-text/zotero-bin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /app-text/zotero-bin
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'app-text/zotero-bin')
-rw-r--r--app-text/zotero-bin/Manifest2
-rw-r--r--app-text/zotero-bin/zotero-bin-6.0.4.ebuild73
2 files changed, 75 insertions, 0 deletions
diff --git a/app-text/zotero-bin/Manifest b/app-text/zotero-bin/Manifest
index d027b7b3d39e..8fa12fd6554a 100644
--- a/app-text/zotero-bin/Manifest
+++ b/app-text/zotero-bin/Manifest
@@ -1,3 +1,5 @@
DIST zotero-bin-5.0.96.3.tar.bz2 61236517 BLAKE2B 3de6d41349f9cc405dd3d44e8e456169d58bdd1f4522c31cd168182878839fe8ca6280eff7339bcf3d66c87c7d4f5af55d768551abcff3cd579342cae37b64e3 SHA512 0777ec41bc151b0bd30076f8a7f59e431c3435728b4d85298421ef11aea5b7c1e122d3bb7fcc5551bb8c4472922796d9508a56df7a0913515d8568fcf3ca6fee
+DIST zotero-bin-6.0.4.tar.bz2 68409133 BLAKE2B 9aeb7cfc8e12f7cdd8aa595fa46564d873c51603295f2dd802ba7ad8baaf59e366fb85d5b98c6614222f98449c800e58b7fb190cbb80a1991beb0c69669d6da2 SHA512 14f759dab9e02253f7be8269575fabedc79556cc81eb1bcfaa5d945280b174545b9f23b2c190824124503f353af6a0416c15ecea99a81f5f000207a1eefe84b9
EBUILD zotero-bin-5.0.96.3.ebuild 1758 BLAKE2B da6782640b9aef3c697d0f60fd1cc87d1b76539e1f4ea1d23628b769d2b0a0230000a0f4707e317fef3792fd6248e950086ffa0aaf14f52c52a18ed3d422caa9 SHA512 4359f979d921def27016d05e3ef65018f8cf6c2bdf8caeb51bbcb3263b88c6129e4ff645a14018d4a45ae024703aea23a3a5782fcc5016fc1d0fba3d79db1357
+EBUILD zotero-bin-6.0.4.ebuild 1772 BLAKE2B 2131d077455d567c5d1d7667a14b6026513020cf6e575afbda0c7b0ef30b4ac55a5d15f710e1d907d3c2ea444c8d5ac9325971c9d252a7ecd3cac5f0c1f9b659 SHA512 dd47676fe9f547aeb3966bb518217e3a583effd50edc05b7da5329b74fe3e43c66d263a19160e87069f7ad35b37382b75dbc0a980adce241bd1036cb686754c5
MISC metadata.xml 398 BLAKE2B ef8965041b1ddb5dafacd8d3b913c2c272b50460607018468446993062620044b77ee4033d9811979768aafba6def9b3e06775d48f8f194f7ca95ec6ad048c5c SHA512 5a67ca8cbadcfa83e38f983b3e448073970e71f2d2a3c0756d8cbbe54050382095df564bdd5e52b0976a9588f882d814a71179957e09e429a2881a7f48041e53
diff --git a/app-text/zotero-bin/zotero-bin-6.0.4.ebuild b/app-text/zotero-bin/zotero-bin-6.0.4.ebuild
new file mode 100644
index 000000000000..831f9a1eb8cf
--- /dev/null
+++ b/app-text/zotero-bin/zotero-bin-6.0.4.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop xdg
+
+DESCRIPTION="Helps you collect, organize, cite, and share your research sources"
+HOMEPAGE="https://www.zotero.org"
+SRC_URI="https://www.zotero.org/download/client/dl?channel=release&platform=linux-x86_64&version=${PV} -> ${P}.tar.bz2"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+RDEPEND="
+ dev-libs/atk
+ dev-libs/dbus-glib
+ dev-libs/glib
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/fontconfig
+ media-libs/freetype
+ sys-apps/dbus
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrender
+ x11-libs/libXt
+ x11-libs/pango
+"
+
+S="${WORKDIR}/Zotero_linux-x86_64"
+
+QA_PREBUILT="opt/zotero/*"
+
+src_prepare() {
+ # disable auto-update
+ sed -i -e 's/\(pref("app.update.enabled"\).*/\1, false);/' defaults/preferences/prefs.js || die
+
+ # disable default oo installation questions - manual installation is still possible
+ sed -i -e 's/\(pref("extensions.zoteroOpenOfficeIntegration.skipInstallation"\).*/\1, true);/' \
+ extensions/zoteroOpenOfficeIntegration@zotero.org/defaults/preferences/zoteroOpenOfficeIntegration.js || die
+
+ # fix desktop-file
+ sed -i -e 's#^Exec=.*#Exec=zotero#' zotero.desktop || die
+ sed -i -e 's#Icon=zotero.*#Icon=zotero#' zotero.desktop || die
+
+ default
+}
+
+src_install() {
+ dodir opt/zotero
+ cp -a "${S}"/* "${ED}/opt/zotero" || die
+
+ dosym ../../opt/zotero/zotero usr/bin/zotero
+
+ domenu zotero.desktop
+
+ for size in 16 32 48 256; do
+ newicon -s ${size} chrome/icons/default/default${size}.png zotero.png
+ done
+}