summaryrefslogtreecommitdiff
path: root/app-text/zathura/zathura-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-26 20:10:49 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-26 20:10:49 +0000
commitc85a90f90521c7e11d618b527d6630cc64cecbd4 (patch)
tree27c1f04d8eab0e0140fb62887a6a5d4d87c32ad9 /app-text/zathura/zathura-9999.ebuild
parent2f51c9978dda4c6e8debca43e4235ecc86914032 (diff)
gentoo resync : 26.12.2017
Diffstat (limited to 'app-text/zathura/zathura-9999.ebuild')
-rw-r--r--app-text/zathura/zathura-9999.ebuild28
1 files changed, 13 insertions, 15 deletions
diff --git a/app-text/zathura/zathura-9999.ebuild b/app-text/zathura/zathura-9999.ebuild
index 52a3a9c5d867..70f20b7aed63 100644
--- a/app-text/zathura/zathura-9999.ebuild
+++ b/app-text/zathura/zathura-9999.ebuild
@@ -3,24 +3,22 @@
EAPI=5
-inherit eutils fdo-mime multilib toolchain-funcs virtualx
-[[ ${PV} == 9999* ]] && inherit git-2
+inherit eutils multilib toolchain-funcs virtualx xdg-utils
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.pwmt.org/pwmt/zathura.git"
+ EGIT_BRANCH="develop"
+else
+ KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+ SRC_URI="http://pwmt.org/projects/${PN}/download/${P}.tar.gz"
+fi
DESCRIPTION="A highly customizable and functional document viewer"
HOMEPAGE="http://pwmt.org/projects/zathura/"
-if ! [[ ${PV} == 9999* ]]; then
-SRC_URI="http://pwmt.org/projects/${PN}/download/${P}.tar.gz"
-fi
-EGIT_REPO_URI="https://git.pwmt.org/pwmt/${PN}.git"
-EGIT_BRANCH="develop"
LICENSE="ZLIB"
SLOT="0"
-if ! [[ ${PV} == 9999* ]]; then
-KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
-else
-KEYWORDS=""
-fi
IUSE="+magic sqlite synctex test"
RDEPEND=">=dev-libs/girara-0.2.7:3=
@@ -35,7 +33,7 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
test? ( dev-libs/check )"
-pkg_setup() {
+src_configure() {
myzathuraconf=(
WITH_MAGIC=$(usex magic 1 0)
WITH_SQLITE=$(usex sqlite 1 0)
@@ -63,9 +61,9 @@ src_install() {
}
pkg_postinst() {
- fdo-mime_desktop_database_update
+ xdg_desktop_database_update
}
pkg_postrm() {
- fdo-mime_desktop_database_update
+ xdg_desktop_database_update
}