summaryrefslogtreecommitdiff
path: root/app-text/zathura/zathura-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
commit36ac65103bf5503e5bad1ecc7e8cb9e7643f6840 (patch)
treed9d1fbc20509d4c90f57fb2d9e1459bc8034c831 /app-text/zathura/zathura-9999.ebuild
parenta1392efe64137262023d92492396ca9156d22396 (diff)
Revert "gentoo resync : 13.09.2019"
This reverts commit a1392efe64137262023d92492396ca9156d22396.
Diffstat (limited to 'app-text/zathura/zathura-9999.ebuild')
-rw-r--r--app-text/zathura/zathura-9999.ebuild43
1 files changed, 24 insertions, 19 deletions
diff --git a/app-text/zathura/zathura-9999.ebuild b/app-text/zathura/zathura-9999.ebuild
index 83ead1f313eb..fcb0645c0898 100644
--- a/app-text/zathura/zathura-9999.ebuild
+++ b/app-text/zathura/zathura-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=6
-inherit meson virtualx
+inherit gnome2-utils meson virtualx xdg-utils
DESCRIPTION="A highly customizable and functional document viewer"
HOMEPAGE="http://pwmt.org/projects/zathura/"
@@ -13,41 +13,36 @@ if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://git.pwmt.org/pwmt/${PN}.git"
EGIT_BRANCH="develop"
else
- SRC_URI="https://github.com/pwmt/zathura/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://pwmt.org/projects/zathura/download/${P}.tar.xz"
KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
fi
LICENSE="ZLIB"
SLOT="0"
-IUSE="doc +magic seccomp sqlite synctex test"
+IUSE="+magic seccomp sqlite synctex test"
-RESTRICT="!test? ( test )"
-
-DEPEND=">=dev-libs/girara-0.3.3
+RDEPEND=">=dev-libs/girara-0.3.1
>=dev-libs/glib-2.50:2
+ dev-python/sphinx
>=sys-devel/gettext-0.19.8
- x11-libs/cairo[X]
+ x11-libs/cairo
>=x11-libs/gtk+-3.22:3
magic? ( sys-apps/file )
seccomp? ( sys-libs/libseccomp )
sqlite? ( >=dev-db/sqlite-3.5.9:3 )
synctex? ( app-text/texlive-core )"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}
+ test? ( dev-libs/check )"
-BDEPEND="doc? ( dev-python/sphinx )
- test? ( dev-libs/appstream-glib
- dev-libs/check )
- virtual/pkgconfig"
+BDEPEND="virtual/pkgconfig"
src_configure() {
local emesonargs=(
- -Dconvert-icon=disabled
- -Dmagic=$(usex magic enabled disabled)
- -Dmanpages=$(usex doc enabled disabled)
- -Dseccomp=$(usex seccomp enabled disabled)
- -Dsqlite=$(usex sqlite enabled disabled)
- -Dsynctex=$(usex synctex enabled disabled)
+ -Denable-magic=$(usex magic true false)
+ -Denable-seccomp=$(usex seccomp true false)
+ -Denable-sqlite=$(usex sqlite true false)
+ -Denable-synctex=$(usex synctex true false)
)
meson_src_configure
}
@@ -55,3 +50,13 @@ src_configure() {
src_test() {
virtx meson_src_test
}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}