summaryrefslogtreecommitdiff
path: root/app-text/zathura-pdf-poppler/zathura-pdf-poppler-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/zathura-pdf-poppler/zathura-pdf-poppler-9999.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/zathura-pdf-poppler/zathura-pdf-poppler-9999.ebuild')
-rw-r--r--app-text/zathura-pdf-poppler/zathura-pdf-poppler-9999.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-text/zathura-pdf-poppler/zathura-pdf-poppler-9999.ebuild b/app-text/zathura-pdf-poppler/zathura-pdf-poppler-9999.ebuild
new file mode 100644
index 000000000000..ca0b8305c134
--- /dev/null
+++ b/app-text/zathura-pdf-poppler/zathura-pdf-poppler-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs xdg
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.pwmt.org/pwmt/zathura-pdf-poppler.git"
+ EGIT_BRANCH="develop"
+else
+ KEYWORDS="~amd64 ~arm ~x86"
+ SRC_URI="http://pwmt.org/projects/zathura/plugins/download/${P}.tar.gz"
+fi
+
+DESCRIPTION="PDF plug-in for zathura"
+HOMEPAGE="http://pwmt.org/projects/zathura/"
+
+LICENSE="ZLIB"
+SLOT="0"
+IUSE=""
+
+RDEPEND="app-text/poppler[cairo]
+ >=app-text/zathura-0.3.8
+ x11-libs/cairo:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ myzathuraconf=(
+ CC="$(tc-getCC)"
+ LD="$(tc-getLD)"
+ VERBOSE=1
+ )
+}
+
+src_compile() {
+ emake "${myzathuraconf[@]}"
+}
+
+src_install() {
+ emake "${myzathuraconf[@]}" DESTDIR="${ED%/}" install
+ dodoc AUTHORS
+}