summaryrefslogtreecommitdiff
path: root/app-text/zathura-pdf-mupdf/zathura-pdf-mupdf-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/zathura-pdf-mupdf/zathura-pdf-mupdf-9999.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/zathura-pdf-mupdf/zathura-pdf-mupdf-9999.ebuild')
-rw-r--r--app-text/zathura-pdf-mupdf/zathura-pdf-mupdf-9999.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/app-text/zathura-pdf-mupdf/zathura-pdf-mupdf-9999.ebuild b/app-text/zathura-pdf-mupdf/zathura-pdf-mupdf-9999.ebuild
new file mode 100644
index 000000000000..8d7a7aa0a007
--- /dev/null
+++ b/app-text/zathura-pdf-mupdf/zathura-pdf-mupdf-9999.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs xdg
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.pwmt.org/pwmt/zathura-pdf-mupdf.git"
+ EGIT_BRANCH="develop"
+else
+ KEYWORDS="~amd64 ~arm ~x86"
+ SRC_URI="https://pwmt.org/projects/zathura/plugins/download/${P}.tar.gz"
+fi
+
+DESCRIPTION="PDF plug-in for zathura"
+HOMEPAGE="https://pwmt.org/projects/zathura/"
+
+LICENSE="ZLIB"
+SLOT="0"
+IUSE=""
+
+RDEPEND="!app-text/zathura-pdf-poppler
+ >=app-text/mupdf-1.12.0:=
+ >=app-text/zathura-0.3.8
+ media-libs/jbig2dec:=
+ media-libs/openjpeg:2=
+ virtual/jpeg:0
+ x11-libs/cairo:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ myzathuraconf=(
+ CC="$(tc-getCC)"
+ LD="$(tc-getLD)"
+ VERBOSE=1
+ DESTDIR="${D}"
+ MUPDF_LIB="$($(tc-getPKG_CONFIG) --libs mupdf)"
+ OPENSSL_INC="$($(tc-getPKG_CONFIG) --cflags mupdf)"
+ OPENSSL_LIB=''
+ )
+}
+
+src_compile() {
+ emake "${myzathuraconf[@]}"
+}
+
+src_install() {
+ emake "${myzathuraconf[@]}" install
+ dodoc AUTHORS
+}