summaryrefslogtreecommitdiff
path: root/app-text/yodl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /app-text/yodl
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'app-text/yodl')
-rw-r--r--app-text/yodl/Manifest2
-rw-r--r--app-text/yodl/yodl-4.02.02.ebuild64
2 files changed, 66 insertions, 0 deletions
diff --git a/app-text/yodl/Manifest b/app-text/yodl/Manifest
index 1fdbd9b7fdbb..cddccdba71ab 100644
--- a/app-text/yodl/Manifest
+++ b/app-text/yodl/Manifest
@@ -1,3 +1,5 @@
DIST yodl-4.02.01.tar.gz 308670 BLAKE2B f94c094f17ec99e66f64a704e41814274f61128ff21b11077d772874dcbc9f15fbc878df8831e7f73d9b6c89a497462c694bc0bdb6cd5637c0db08303e3838d5 SHA512 59e23bb173786b8806f56bf302dee9d8d971d0d840c609e2b24d9783b5866fca2509be844616318f9a4f302117b3a41f620be5cba09181e7ccdcf0c141402be7
+DIST yodl-4.02.02.tar.gz 309075 BLAKE2B ce9da287ca59e20319ae8a132553b669ffff926c79e7ffbf7891af3e777c45815cbd784eaf8d706b7f4b8240ceac41c38882c7b5d2b51e2691da249b0f5be43b SHA512 531b5b61f85ed556163b0cf76a30451212849e5e03e11819cc466603db0856737a9d3bc34ba11419befd7925ec1bac33f92b707c38acd2fa8047e3e1223d0a78
EBUILD yodl-4.02.01.ebuild 1184 BLAKE2B 7547e9d39fd312c30e1d465cec9f95fc15ef1acfd04e45af85105b95ef57a5fa8a24949d2d70348c9c03a89a060c59a785f771f0a70eb99b673753c0ea939bfd SHA512 a33e23178c78cad05f8f3c1e1b67cab2676706e2c989346a823c993ee3ac60dbe3c303a01c71d38ef9bb5cbcbd8ef039e0ef63c8cec52409a9ed200a6d53dbf4
+EBUILD yodl-4.02.02.ebuild 1634 BLAKE2B a79333320d7ee5e49e0980ff33ac83c38dfd9b6ab68deaf02e5573481f39762189aa682994d759cbd570a0150a12ba7d2e2c5246409edc5ac350962cf8ccfa3d SHA512 d0daf25c56ed5e7efb7503ed691a6133f77910fcbe42a415e5be251bda1cb740978795198c122b955f9ab2b1db9c3b585973a85c0d8b0fb547f473f6ce93efa8
MISC metadata.xml 244 BLAKE2B 256b5e0596820baf1555605a91d2b5a2454bd96180ac95ea34b705405212a37eca42f21754f8f11f875607f97b82badc149211361ec253226593297d867d1376 SHA512 4116d229be9545299fb52d43d3c5f3f1bcd44e53ebb05483cf231f05d76758b59a6a1a6b7b2eb0fc78304dc3a2422d9ba70c89ac159eef4afbcc5730b58f297e
diff --git a/app-text/yodl/yodl-4.02.02.ebuild b/app-text/yodl/yodl-4.02.02.ebuild
new file mode 100644
index 000000000000..25f75b909934
--- /dev/null
+++ b/app-text/yodl/yodl-4.02.02.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="Your Own Document Language: a pre-document language and tools to process it"
+HOMEPAGE="https://fbb-git.gitlab.io/yodl/ https://gitlab.com/fbb-git/yodl"
+SRC_URI="https://gitlab.com/fbb-git/${PN}/-/archive/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND=">=dev-util/icmake-8.00.00"
+
+S=${WORKDIR}/${P}/${PN}
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != "binary" ]]; then
+ if tc-is-gcc && [[ $(gcc-major-version) -lt 8 ]]; then
+ die "Your compiler doesn't fully support C++17. Use GCC 8 or newer."
+ elif tc-is-clang && [[ $(clang-major-version) -lt 6 ]]; then
+ die "Your compiler doesn't fully support C++17. Use Clang 6 or newer."
+ fi
+ fi
+}
+
+src_prepare() {
+ sed -e "/DOC.* =/s/yodl\(-doc\)\?/${PF}/" \
+ -e "/COMPILER =/s/gcc/$(tc-getCC)/" \
+ -e "/CXX =/s/g++/$(tc-getCXX)/" \
+ -i INSTALL.im || die
+
+ sed -e "s/g++/$(tc-getCXX)/" \
+ -e "s:#define CLS://\0:" \
+ -i verbinsert/icmconf || die
+
+ sed -e "s/ar r /$(tc-getAR) r /" \
+ -e "s/ranlib/$(tc-getRANLIB)/" \
+ -i icmake/stdcompile || die
+
+ # required for std::filesystem usage
+ append-cxxflags -std=c++17
+
+ default
+}
+
+src_compile() {
+ ./build programs || die
+ ./build macros || die
+ ./build man || die
+ use doc && { ./build manual || die ; }
+}
+
+src_install() {
+ ./build install programs "${ED}" || die
+ ./build install macros "${ED}" || die
+ ./build install man "${ED}" || die
+ ./build install docs "${ED}" || die
+ use doc && { ./build install manual "${ED}" || die ; }
+}