summaryrefslogtreecommitdiff
path: root/app-text/yelp-tools/yelp-tools-40.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /app-text/yelp-tools/yelp-tools-40.0.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'app-text/yelp-tools/yelp-tools-40.0.ebuild')
-rw-r--r--app-text/yelp-tools/yelp-tools-40.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-text/yelp-tools/yelp-tools-40.0.ebuild b/app-text/yelp-tools/yelp-tools-40.0.ebuild
new file mode 100644
index 000000000000..89f69c203b36
--- /dev/null
+++ b/app-text/yelp-tools/yelp-tools-40.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+inherit gnome2 meson python-single-r1
+
+DESCRIPTION="Collection of tools for building and converting documentation"
+HOMEPAGE="https://wiki.gnome.org/Apps/Yelp/Tools"
+
+LICENSE="|| ( GPL-2+ freedist ) GPL-2+" # yelp.m4 is GPL2 || freely distributable
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/lxml[${PYTHON_USEDEP}]')
+ >=dev-libs/libxml2-2.6.12
+ >=dev-libs/libxslt-1.1.8
+ dev-util/itstool
+ >=gnome-extra/yelp-xsl-3.38
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ meson_src_install
+ python_fix_shebang "${ED}"/usr/bin/yelp-{build,check,new}
+}