summaryrefslogtreecommitdiff
path: root/app-text/xournalpp/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-10 05:36:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-10 05:36:05 +0100
commit4bbcd26e7cb1908fb98bb318bfaa13ea9e32d860 (patch)
tree39e9258a61ef296b0e5afba0c7dc2557891487c4 /app-text/xournalpp/files
parent47d5e233005d470dbd431a280e64ce6073fc7149 (diff)
gentoo auto-resync : 10:04:2023 - 05:36:05
Diffstat (limited to 'app-text/xournalpp/files')
-rw-r--r--app-text/xournalpp/files/xournalpp-1.1.3-gcc13.patch12
-rw-r--r--app-text/xournalpp/files/xournalpp-1.1.3-lua-5-4.patch14
2 files changed, 26 insertions, 0 deletions
diff --git a/app-text/xournalpp/files/xournalpp-1.1.3-gcc13.patch b/app-text/xournalpp/files/xournalpp-1.1.3-gcc13.patch
new file mode 100644
index 000000000000..97f7fbc0d7f2
--- /dev/null
+++ b/app-text/xournalpp/files/xournalpp-1.1.3-gcc13.patch
@@ -0,0 +1,12 @@
+https://bugs.gentoo.org/894720
+https://bugs.gentoo.org/895536
+--- a/src/view/background/BackgroundConfig.h
++++ b/src/view/background/BackgroundConfig.h
+@@ -11,6 +11,7 @@
+
+ #pragma once
+
++#include <cstdint>
+ #include <map>
+ #include <string>
+
diff --git a/app-text/xournalpp/files/xournalpp-1.1.3-lua-5-4.patch b/app-text/xournalpp/files/xournalpp-1.1.3-lua-5-4.patch
new file mode 100644
index 000000000000..c53b63588c43
--- /dev/null
+++ b/app-text/xournalpp/files/xournalpp-1.1.3-lua-5-4.patch
@@ -0,0 +1,14 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -148,9 +148,9 @@ if (ENABLE_CPPUNIT)
+ endif (ENABLE_CPPUNIT)
+
+ # Plugins / scripting
+-find_package (Lua 5.3 EXACT)
++find_package (Lua ${LUA_VERSION} EXACT)
+ if (NOT Lua_FOUND)
+- find_package (Lua 5.3) # Lua 5.4 is only supported with cmake >=3.18
++ find_package (Lua ${LUA_VERSION}) # Lua 5.4 is only supported with cmake >=3.18
+ endif()
+
+ if (Lua_FOUND)