summaryrefslogtreecommitdiff
path: root/app-text/xmlformat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/xmlformat
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/xmlformat')
-rw-r--r--app-text/xmlformat/Manifest3
-rw-r--r--app-text/xmlformat/metadata.xml5
-rw-r--r--app-text/xmlformat/xmlformat-1.04.ebuild51
3 files changed, 59 insertions, 0 deletions
diff --git a/app-text/xmlformat/Manifest b/app-text/xmlformat/Manifest
new file mode 100644
index 000000000000..57607ef30105
--- /dev/null
+++ b/app-text/xmlformat/Manifest
@@ -0,0 +1,3 @@
+DIST xmlformat-1.04.tar.gz 156498 BLAKE2B 18463dea611a5d080056b0ed314eb12555e2abb12d630fb879421fa6359606f7606fda42e146eaaea7ae2fa470661ab4e28a86762375024704e607316f6323cf SHA512 e45471accf0c04e016d3a9a5bbc2f984a9a76e1d5406a80300bf9da9d04bd78b67716055271923669462b70a1713b94a1e1937318115dfd9eb9d258b69a3c14d
+EBUILD xmlformat-1.04.ebuild 971 BLAKE2B 571ca3d2dc069aa83f71adb8a21a63169ebf2f236b62c958aed58c4e0788ad8b66f8a7a286318b0d9be5f0f977a2decbc99e93812e5f5e969d1387971e74aa2f SHA512 3b7e3e29a617fe595fc2caf741284e3b5a211caa481e110db0e4f9aac9494a5b693b6c9ba09cd5e532843dc0faddc268b45f1c118bff7619670ad77aec34436f
+MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/app-text/xmlformat/metadata.xml b/app-text/xmlformat/metadata.xml
new file mode 100644
index 000000000000..6f49eba8f496
--- /dev/null
+++ b/app-text/xmlformat/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+</pkgmetadata>
diff --git a/app-text/xmlformat/xmlformat-1.04.ebuild b/app-text/xmlformat/xmlformat-1.04.ebuild
new file mode 100644
index 000000000000..b91035f55bd4
--- /dev/null
+++ b/app-text/xmlformat/xmlformat-1.04.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+inherit ruby-single
+
+DESCRIPTION="Reformat XML documents to your custom style"
+SRC_URI="http://www.kitebird.com/software/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.kitebird.com/software/xmlformat/"
+
+SLOT="0"
+LICENSE="xmlformat"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+DEPEND="ruby? ( ${RUBY_DEPS} )
+ !ruby? ( dev-lang/perl )"
+RDEPEND=${DEPEND}
+IUSE="ruby doc"
+
+src_install() {
+ dobin xmlformat.pl
+
+ if use ruby
+ then
+ dobin xmlformat.rb
+ dosym xmlformat.rb /usr/bin/xmlformat
+ else
+ dosym xmlformat.pl /usr/bin/xmlformat
+ fi
+
+ dodoc BUGS ChangeLog README TODO
+
+ if use doc
+ then
+ # APIs
+ insinto /usr/share/doc/${PF}
+ doins -r docs/*
+ fi
+}
+
+src_test() {
+ if use ruby
+ then
+ ./runtest all || die "runtest for ruby failed."
+ else
+ ./runtest -p all || die "runtest for perl failed."
+ fi
+}