summaryrefslogtreecommitdiff
path: root/app-text/xmlformat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
commit7218e1b46bceac05841e90472501742d905fb3fc (patch)
tree56fae051db521b8fce8014cbc8b11484885b14b3 /app-text/xmlformat
parent6d691ad5b6239929063441bbd14c489e92e7396e (diff)
gentoo resync : 12.03.2021
Diffstat (limited to 'app-text/xmlformat')
-rw-r--r--app-text/xmlformat/Manifest2
-rw-r--r--app-text/xmlformat/xmlformat-1.04.ebuild29
2 files changed, 14 insertions, 17 deletions
diff --git a/app-text/xmlformat/Manifest b/app-text/xmlformat/Manifest
index 7a88a0c39759..22f98829aa2d 100644
--- a/app-text/xmlformat/Manifest
+++ b/app-text/xmlformat/Manifest
@@ -1,3 +1,3 @@
DIST xmlformat-1.04.tar.gz 156498 BLAKE2B 18463dea611a5d080056b0ed314eb12555e2abb12d630fb879421fa6359606f7606fda42e146eaaea7ae2fa470661ab4e28a86762375024704e607316f6323cf SHA512 e45471accf0c04e016d3a9a5bbc2f984a9a76e1d5406a80300bf9da9d04bd78b67716055271923669462b70a1713b94a1e1937318115dfd9eb9d258b69a3c14d
-EBUILD xmlformat-1.04.ebuild 961 BLAKE2B e367356edd902f01698fcea9447ffd504c66e8f7d17918a5354ad0a1df4428f682354c0e16a83b982d5bf09e25ecec0e9770289f573a7489c612a498c9e175e2 SHA512 24e4c400d9611df4df428670eda1b6ca0059198fd667a8a086f97e86ad5c3871b1e3b7a0f33ae834db2c424fd54e86a45e3ebf7e48a297306e3906152a74ad7a
+EBUILD xmlformat-1.04.ebuild 934 BLAKE2B e7f14a90ccfc8c529eadad43d641cd2f1c4ec04560b634822534a15793df1d86164e43acc2b0ea120f5645eef0cffd34ad03715ed777851e731da78b8f7003af SHA512 6191ac9a87aa91b95d004e1762ea94ca66f25a919f2a3df1b677f73b01c156e16fb08163c7a218d1e80012aa6b0bd97f2231d14e34452e6436d630b2e49f1ff0
MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/app-text/xmlformat/xmlformat-1.04.ebuild b/app-text/xmlformat/xmlformat-1.04.ebuild
index 044ee876c257..7e10ca1cc039 100644
--- a/app-text/xmlformat/xmlformat-1.04.ebuild
+++ b/app-text/xmlformat/xmlformat-1.04.ebuild
@@ -1,30 +1,30 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
USE_RUBY="ruby24 ruby25 ruby26"
-
inherit ruby-single
DESCRIPTION="Reformat XML documents to your custom style"
SRC_URI="http://www.kitebird.com/software/${PN}/${P}.tar.gz"
HOMEPAGE="http://www.kitebird.com/software/xmlformat/"
-SLOT="0"
LICENSE="xmlformat"
+SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc ruby"
-DEPEND="ruby? ( ${RUBY_DEPS} )
- !ruby? ( dev-lang/perl )"
-RDEPEND=${DEPEND}
-IUSE="ruby doc"
+DEPEND="
+ ruby? ( ${RUBY_DEPS} )
+ !ruby? ( dev-lang/perl )
+"
+RDEPEND="${DEPEND}"
src_install() {
dobin xmlformat.pl
- if use ruby
- then
+ if use ruby; then
dobin xmlformat.rb
dosym xmlformat.rb /usr/bin/xmlformat
else
@@ -33,17 +33,14 @@ src_install() {
dodoc BUGS ChangeLog README TODO
- if use doc
- then
+ if use doc; then
# APIs
- insinto /usr/share/doc/${PF}
- doins -r docs/*
+ dodoc -r docs/*
fi
}
src_test() {
- if use ruby
- then
+ if use ruby; then
./runtest all || die "runtest for ruby failed."
else
./runtest -p all || die "runtest for perl failed."