summaryrefslogtreecommitdiff
path: root/app-text/xmlformat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-07 23:31:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-07 23:31:01 +0100
commit11e4049d80ff5ce2aa21c2bb5dab36897e5359e9 (patch)
tree8a9bf6a29e45cb7a9c9cdc39be9dcda18917cd1a /app-text/xmlformat
parentdebb2c431b40a6b4750a39956cc5fcfa5a4a6476 (diff)
gentoo auto-resync : 07:04:2023 - 23:31:01
Diffstat (limited to 'app-text/xmlformat')
-rw-r--r--app-text/xmlformat/Manifest2
-rw-r--r--app-text/xmlformat/xmlformat-1.04.ebuild25
2 files changed, 14 insertions, 13 deletions
diff --git a/app-text/xmlformat/Manifest b/app-text/xmlformat/Manifest
index bc2afdc4ce5a..453419e970e9 100644
--- a/app-text/xmlformat/Manifest
+++ b/app-text/xmlformat/Manifest
@@ -1,3 +1,3 @@
DIST xmlformat-1.04.tar.gz 156498 BLAKE2B 18463dea611a5d080056b0ed314eb12555e2abb12d630fb879421fa6359606f7606fda42e146eaaea7ae2fa470661ab4e28a86762375024704e607316f6323cf SHA512 e45471accf0c04e016d3a9a5bbc2f984a9a76e1d5406a80300bf9da9d04bd78b67716055271923669462b70a1713b94a1e1937318115dfd9eb9d258b69a3c14d
-EBUILD xmlformat-1.04.ebuild 927 BLAKE2B e5227a99b47a652f978ddd4e2ec056c8f7d173469081f01fe32d96176989ee27d9fc4ca32145f2c237306fd49d1cee8baa395d49916a24b7d3532f8a14939a3c SHA512 33cd2acbbbef741061ce65d4ef31c373cb58033653b17772da202c56d9477d0ce81dc1d976b39cba45194f5f13957b7c9c23b19a52e631c8905d97eb763469fc
+EBUILD xmlformat-1.04.ebuild 1017 BLAKE2B c9b842b733675f39b2e98dcd15d257b26f1df6d87025111c2adf307480fb4c621133e822b53524935a4d0c23e8c9daf7e373fc8429f0e5543b444019699ee031 SHA512 f8f6dd77f7e6b02ec35a2992d84b22ac66613d50fb6d01ae621d69ca4d9fd87b6d45581e107c1c826dd5b21e092e50963278a4e9aea1387b09e416a6e67a0896
MISC metadata.xml 167 BLAKE2B 868e3b584722eaacf68273db062bb773d8c7e5d7ab2b81ca7e8397643bf7cc106c3a1033594401c99c54f667bb45d6b73f9048fc335580bbd44b4589ad26a832 SHA512 30caadd1496c3b9969136038239a1d8e01f236726b4022c2d7e19ca7575f25f735e556835e581afbf44fbd3e4104c40f2b5ef5fa70118d75c881fdf871962d0a
diff --git a/app-text/xmlformat/xmlformat-1.04.ebuild b/app-text/xmlformat/xmlformat-1.04.ebuild
index 7dd8954575e8..6abdd5883fc8 100644
--- a/app-text/xmlformat/xmlformat-1.04.ebuild
+++ b/app-text/xmlformat/xmlformat-1.04.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-USE_RUBY="ruby27 ruby30"
-inherit ruby-single
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+inherit edo ruby-single
DESCRIPTION="Reformat XML documents to your custom style"
SRC_URI="http://www.kitebird.com/software/${PN}/${P}.tar.gz"
@@ -16,11 +16,20 @@ KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="doc ruby"
DEPEND="
+ dev-lang/perl
ruby? ( ${RUBY_DEPS} )
- !ruby? ( dev-lang/perl )
"
RDEPEND="${DEPEND}"
+src_test() {
+ # Perl is always installed, so we may as well always test both.
+ if use ruby; then
+ nonfatal edo ./runtest all || die "runtest for ruby failed"
+ fi
+
+ nonfatal edo ./runtest -p all || die "runtest for perl failed"
+}
+
src_install() {
dobin xmlformat.pl
@@ -38,11 +47,3 @@ src_install() {
dodoc -r docs/*
fi
}
-
-src_test() {
- if use ruby; then
- ./runtest all || die "runtest for ruby failed."
- else
- ./runtest -p all || die "runtest for perl failed."
- fi
-}