summaryrefslogtreecommitdiff
path: root/app-text/xmldiff
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-22 17:18:34 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-22 17:18:34 +0000
commitfd87b7c771378b2116981e3924bee5805148e118 (patch)
tree91ed28393c7b534787d3c073e269fe598d0fd535 /app-text/xmldiff
parent77b74be093bdf4a0ed4121acc3f8e229103cf004 (diff)
gentoo auto-resync : 22:11:2023 - 17:18:34
Diffstat (limited to 'app-text/xmldiff')
-rw-r--r--app-text/xmldiff/Manifest4
-rw-r--r--app-text/xmldiff/metadata.xml2
-rw-r--r--app-text/xmldiff/xmldiff-2.6.3.ebuild27
3 files changed, 32 insertions, 1 deletions
diff --git a/app-text/xmldiff/Manifest b/app-text/xmldiff/Manifest
index 5c03b72a9b4f..a541c4a5fd18 100644
--- a/app-text/xmldiff/Manifest
+++ b/app-text/xmldiff/Manifest
@@ -1,3 +1,5 @@
DIST xmldiff-2.4.tar.gz 93437 BLAKE2B 9f0001da8e39b7a3e7d0af052ce60a43899b2cd644b3fa6c6cb7cfa08ebf71439bda3e3dc6cf497120f20cb0f9346b0a074b8e442b42531fd3bdbaaebdf73bf6 SHA512 d8a0c9cb850259b3288d8fb5fde50c69f24036bc46ea48f24f3d63c592ccdd2aab4daf416f0f75b38fd70cc58e00c12db626e61a983d1a002972a6720d62c6ae
+DIST xmldiff-2.6.3.tar.gz 86132 BLAKE2B 9e5777f498677bf12a603d6636833d4942fb1af2c461e9a60e2dccf89c3776f72018407928991c8a9f53abe8c704ca9a736a4f0f81ce3ca23e1657a896d43804 SHA512 ba25b8cc9866c66bc829a82d1f20108c17a09e2f46735763317f7fd6f60c3920ba6d3114454ead1461de4a59c177065291bb71bebb7ee9c4a03f3584452a9e33
EBUILD xmldiff-2.4.ebuild 638 BLAKE2B 7b11701d6601a0503bdf6c93c85b3e0e2b2070f990b874d75bad06b2de7bae639ba23c975d185e9e27e3526da25ffa1763d1220a99d9c15fc316e2132f6d0318 SHA512 988dc5cde3cc90b2a61c34ab3c6b0f32b864134416879717b6ad5f4f204d2f53cd3d96faf3477ce4d127bfd66d5d55f0d9750f7cb1da8f150b2d70818dfb50e9
-MISC metadata.xml 572 BLAKE2B 45cfe3e3e9fbfcb886a0682c3954dd02a6918892fff0bc11f683e44a49b1c0bbd09bdb8d85b5cd49741e2d9fb9c79fad09660d7fdf6e964f6b214ca61d54b127 SHA512 71e6dc811470b0d130f3af1099aba37373b392232f2e1c8caf470c24731cd0e5c24d81e6efed77af51af68fd180e18dac2fbba28a3743b6ce9d47dff9debbbbc
+EBUILD xmldiff-2.6.3.ebuild 580 BLAKE2B e536748d3520d8c6461fbaf15293ec75c4b7f2b6fe1d1674f6d29a7dba209df41d53ed25e04c6a978430fdb9540379cbaff3f1970325d7905ff2c1011bfc28e4 SHA512 19719243ccaae4fb61b7ed4da132698b46460c84faeb97eafea1e9cca8f3abcf40750c4021d3862a3f221e9473abc17b15da3683424d8ffec0652b298dc753b0
+MISC metadata.xml 661 BLAKE2B 118804d4908cb78863d8daec482c6e9f60a565da13068e75e2d99f069bcaae47d40e9a54a7bfc53476f1a199e891aea34c9f699be52541e6cb5cd62f321334fd SHA512 c7dc45b2014cedde528216c48e1eb77ad6182840795b30d6339cc7084729e03a728c84f687225948f0b0e045e95abd1f8b66c8af144a6a85d574daad805012e1
diff --git a/app-text/xmldiff/metadata.xml b/app-text/xmldiff/metadata.xml
index ba7acd516129..ca7003827fef 100644
--- a/app-text/xmldiff/metadata.xml
+++ b/app-text/xmldiff/metadata.xml
@@ -10,6 +10,8 @@
with XML files or DOM trees.
</longdescription>
<upstream>
+ <doc>https://xmldiff.readthedocs.io</doc>
<remote-id type="github">Shoobx/xmldiff</remote-id>
+ <remote-id type="pypi">xmldiff</remote-id>
</upstream>
</pkgmetadata>
diff --git a/app-text/xmldiff/xmldiff-2.6.3.ebuild b/app-text/xmldiff/xmldiff-2.6.3.ebuild
new file mode 100644
index 000000000000..98cfbbde2b9a
--- /dev/null
+++ b/app-text/xmldiff/xmldiff-2.6.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A tool that figures out the differences between two similar XML files"
+HOMEPAGE="
+ https://github.com/Shoobx/xmldiff
+ https://pypi.org/project/xmldiff/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-linux"
+
+RDEPEND="
+ >=dev-python/lxml-3.1.0[${PYTHON_USEDEP}]
+"
+
+DOCS=( CHANGES.rst README.rst )
+
+distutils_enable_tests unittest