summaryrefslogtreecommitdiff
path: root/app-text/xdvik
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /app-text/xdvik
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'app-text/xdvik')
-rw-r--r--app-text/xdvik/Manifest1
-rw-r--r--app-text/xdvik/xdvik-22.87.03-r4.ebuild114
2 files changed, 115 insertions, 0 deletions
diff --git a/app-text/xdvik/Manifest b/app-text/xdvik/Manifest
index 128faca5bfc8..b98952571e05 100644
--- a/app-text/xdvik/Manifest
+++ b/app-text/xdvik/Manifest
@@ -2,4 +2,5 @@ AUX xdvik-22.87.03-freetype2-config.patch 1019 BLAKE2B a675a238fb147dcb67eda572b
AUX xdvik.xpm 3125 BLAKE2B 97990fbd5b22e51319c3f55bfe16808b01f215a92185a170620c8c0ef1dc44906e38af48ad056d4fb40a1777f92a88afaa0f80c0b36e7dd770954f7009d261a3 SHA512 697c888c481d7cbe7b42980d2ae93a8d25d781f926970d9040f8fbc6a37545349fbdbe2e8c98fb686e5a5ebe9a7a5ff661793d3a264fd8641182b0397365517d
DIST xdvik-22.87.03.tar.gz 4760306 BLAKE2B d242696fadf2980cd307d4a172d2af06d98d07b090279440117f869c9a623bcade8745d7a4d3c108c4eafbdeaadefb8d5ba1ea00bdf77d350cbf83c49c2ca0fb SHA512 d4d418d78658f16d4d278e387ed484b291afc8623b00acaf4110e9f123ed76568714ad50f80588373657f412e8fff36f3e76b3e43f69756d46f031c0f2269a88
EBUILD xdvik-22.87.03-r3.ebuild 2905 BLAKE2B d3534e59c513372e72eaf48ed34b09b89542688deab3d03a22bbae30c45b991dd91a9fdcdc728a34ac1c0ff23572810e78731636893821d4aa779226f67205f4 SHA512 f871231eb081e65bf03dfcbdc9c09cc561a74074a806477132d5cd1ffff37fbc70aa62bfb15eba6978a49449ee78e5ba05d45ef5e20070ce23f0089478ffa989
+EBUILD xdvik-22.87.03-r4.ebuild 2848 BLAKE2B e54f9824147cf6f68f715130858afa2f13d41fc13b03a49ec765b99c2245c95425a0a1faaae2dc30bb9d3b9dce6041925c40483ab3f18fed87a3a13c2d5ff1f5 SHA512 09df79a5212b12925af40e9ed01c88b3b10c1944dd5fd685a7c3e50189094ae9f527d96877fca08067fc81c01239b2351828e3a3e6ec10bc816d424a878282ad
MISC metadata.xml 595 BLAKE2B 200debd0214e5985f3f59cabdac72252b556edef5224c77f5dbd91de347f57ab492dd0f7ce846c335179344bc9215b02af61572ff859c9c44ca947235ce5062b SHA512 bf925b9c9738c62f26ebbb2f88782597d6cee471a19258b553e0dc7aa397443149adfceba6cfcdd045196eecc3319541b980850ba5e572f51266da1945b65e4a
diff --git a/app-text/xdvik/xdvik-22.87.03-r4.ebuild b/app-text/xdvik/xdvik-22.87.03-r4.ebuild
new file mode 100644
index 000000000000..1d19d16bb0f7
--- /dev/null
+++ b/app-text/xdvik/xdvik-22.87.03-r4.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools desktop elisp-common flag-o-matic toolchain-funcs xdg
+
+DESCRIPTION="DVI previewer for X Window System"
+HOMEPAGE="http://xdvi.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xdvi/${P}.tar.gz"
+S="${WORKDIR}"/${P}/texk/xdvik
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="motif neXt Xaw3d emacs"
+
+DEPEND=">=media-libs/freetype-2.9.1-r2:2
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXpm
+ x11-libs/libXt
+ emacs? ( >=app-editors/emacs-23.1:* )
+ motif? ( >=x11-libs/motif-2.3:0 )
+ !motif? (
+ neXt? ( x11-libs/neXtaw )
+ !neXt? (
+ Xaw3d? ( x11-libs/libXaw3d )
+ !Xaw3d? ( x11-libs/libXaw )
+ )
+ )
+ dev-libs/kpathsea:="
+RDEPEND="${DEPEND}
+ virtual/latex-base
+ !<app-text/texlive-2007"
+BDEPEND="sys-devel/flex
+ virtual/yacc
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # Make sure system kpathsea headers are used
+ cd "${WORKDIR}/${P}/texk/kpathsea" || die
+ local i
+ for i in *.h ; do
+ echo "#include_next \"$i\"" > ${i} || die
+ done
+
+ cd "${WORKDIR}/${P}" || die
+ eapply "${FILESDIR}"/${P}-freetype2-config.patch
+ cd "${S}" || die
+ eautoreconf
+}
+
+src_configure() {
+ has_version '>=dev-libs/kpathsea-6.2.1' && append-cppflags "$($(tc-getPKG_CONFIG) --cflags kpathsea)"
+
+ local toolkit
+ if use motif ; then
+ toolkit="motif"
+ use neXt && ewarn "neXt USE flag ignored (superseded by motif)"
+ use Xaw3d && ewarn "Xaw3d USE flag ignored (superseded by motif)"
+ elif use neXt ; then
+ toolkit="neXtaw"
+ use Xaw3d && ewarn "Xaw3d USE flag ignored (superseded by neXt)"
+ elif use Xaw3d ; then
+ toolkit="xaw3d"
+ else
+ toolkit="xaw"
+ fi
+
+ econf \
+ --with-system-freetype2 \
+ --with-system-kpathsea \
+ --with-kpathsea-include="${EPREFIX}"/usr/include/kpathsea \
+ --with-xdvi-x-toolkit="${toolkit}" \
+ --x-includes="${ESYSROOT}"/usr/include \
+ --x-libraries="${ESYSROOT}"/usr/$(get_libdir)
+}
+
+src_compile() {
+ emake kpathsea_dir="${EPREFIX}"/usr/include/kpathsea
+
+ use emacs && elisp-compile xdvi-search.el
+}
+
+src_install() {
+ dodir /usr/share/texmf-dist/dvips/config
+
+ emake DESTDIR="${D}" install
+
+ dosym ../../texmf-dist/xdvi/XDvi /usr/share/X11/app-defaults/XDvi
+
+ dodoc BUGS FAQ README.*
+
+ use emacs && elisp-install tex-utils *.el *.elc
+
+ doicon "${FILESDIR}"/${PN}.xpm
+ make_desktop_entry xdvi "XDVI" xdvik "Graphics;Viewer"
+ echo "MimeType=application/x-dvi;" >> "${ED}"/usr/share/applications/xdvi-"${PN}".desktop
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ if use emacs; then
+ elog "Add"
+ elog " (add-to-list 'load-path \"${EPREFIX}${SITELISP}/tex-utils\")"
+ elog " (require 'xdvi-search)"
+ elog "to your ~/.emacs file"
+ fi
+}