summaryrefslogtreecommitdiff
path: root/app-text/xchm/xchm-1.29.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /app-text/xchm/xchm-1.29.ebuild
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'app-text/xchm/xchm-1.29.ebuild')
-rw-r--r--app-text/xchm/xchm-1.29.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/app-text/xchm/xchm-1.29.ebuild b/app-text/xchm/xchm-1.29.ebuild
new file mode 100644
index 000000000000..8a1516c32201
--- /dev/null
+++ b/app-text/xchm/xchm-1.29.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+WX_GTK_VER="3.0-gtk3"
+inherit autotools wxwidgets xdg-utils
+
+DESCRIPTION="Utility for viewing Compiled HTML Help (CHM) files"
+HOMEPAGE="https://github.com/rzvncj/xCHM/"
+SRC_URI="${HOMEPAGE}releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+
+RDEPEND="
+ >=dev-libs/chmlib-0.36
+ x11-libs/wxGTK:${WX_GTK_VER}[X]
+ nls? ( virtual/libintl )
+"
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+"
+
+src_prepare() {
+ setup-wxwidgets
+ default
+ eautoreconf # Still needed on the next release?
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc AUTHORS README ChangeLog
+
+ cp "${D}"/usr/share/pixmaps/xchm-32.xpm "${D}"/usr/share/pixmaps/xchm.xpm
+ rm -f "${D}"/usr/share/pixmaps/xchm-*.xpm
+ rm -f "${D}"/usr/share/pixmaps/xchmdoc*.xpm
+
+ domenu "${FILESDIR}"/xchm.desktop
+ insinto /usr/share/mime/packages
+ doins "${FILESDIR}"/xchm.xml
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}