summaryrefslogtreecommitdiff
path: root/app-text/xapers/xapers-0.9.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /app-text/xapers/xapers-0.9.0.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'app-text/xapers/xapers-0.9.0.ebuild')
-rw-r--r--app-text/xapers/xapers-0.9.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-text/xapers/xapers-0.9.0.ebuild b/app-text/xapers/xapers-0.9.0.ebuild
new file mode 100644
index 000000000000..56850c3d6e19
--- /dev/null
+++ b/app-text/xapers/xapers-0.9.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2016-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Personal document indexing system"
+HOMEPAGE="https://finestructure.net/xapers/ https://gitlab.com/jrollins/xapers/"
+SRC_URI="https://gitlab.com/jrollins/${PN}/-/archive/${PV}/${P}.tar.gz"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="app-text/poppler[utils]
+ dev-libs/xapian-bindings[python,${PYTHON_USEDEP}]
+ dev-python/pybtex[${PYTHON_USEDEP}]
+ dev-python/pycurl[${PYTHON_USEDEP}]
+ dev-python/urwid[${PYTHON_USEDEP}]
+ x11-misc/xclip
+ x11-misc/xdg-utils"
+
+BDEPEND="test? ( ${RDEPEND} )"
+
+src_test() {
+ cd test || die
+ ./all || die
+}