summaryrefslogtreecommitdiff
path: root/app-text/wv/wv-1.2.9-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/wv/wv-1.2.9-r2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/wv/wv-1.2.9-r2.ebuild')
-rw-r--r--app-text/wv/wv-1.2.9-r2.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/app-text/wv/wv-1.2.9-r2.ebuild b/app-text/wv/wv-1.2.9-r2.ebuild
new file mode 100644
index 000000000000..e80da09ffb16
--- /dev/null
+++ b/app-text/wv/wv-1.2.9-r2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils autotools
+
+DESCRIPTION="Tool for conversion of MSWord doc and rtf files to something readable"
+SRC_URI="http://abiword.org/downloads/${PN}/${PV}/${P}.tar.gz"
+HOMEPAGE="http://wvware.sourceforge.net/"
+
+IUSE="tools wmf"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-solaris"
+SLOT="0"
+LICENSE="GPL-2"
+
+RDEPEND="
+ >=dev-libs/glib-2:2
+ >=gnome-extra/libgsf-1.13:=
+ sys-libs/zlib
+ media-libs/libpng:0=
+ dev-libs/libxml2:2
+ tools? ( app-text/texlive-core
+ dev-texlive/texlive-latex )
+ wmf? ( >=media-libs/libwmf-0.2.2 )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+PATCHES=( "${FILESDIR}/${P}-format-security.patch" )
+
+src_prepare() {
+ default
+
+ if ! use tools; then
+ sed -i -e '/bin_/d' GNUmakefile.am || die
+ sed -i -e '/SUBDIRS/d' GNUmakefile.am || die
+ sed -i -e '/\/GNUmakefile/d' configure.ac || die
+ sed -i -e '/wv[[:upper:]]/d' configure.ac || die
+
+ # automake-1.13 fix, bug #467620
+ sed -i -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' configure.ac || die
+
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_with wmf libwmf)
+}
+
+src_install () {
+ default
+ prune_libtool_files
+
+ rm -f "${ED}"/usr/share/man/man1/wvConvert.1
+ if use tools; then
+ dosym /usr/share/man/man1/wvWare.1 /usr/share/man/man1/wvConvert.1 || die
+ fi
+}