summaryrefslogtreecommitdiff
path: root/app-text/wiki2beamer/wiki2beamer-0.9.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/wiki2beamer/wiki2beamer-0.9.5-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/wiki2beamer/wiki2beamer-0.9.5-r1.ebuild')
-rw-r--r--app-text/wiki2beamer/wiki2beamer-0.9.5-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-text/wiki2beamer/wiki2beamer-0.9.5-r1.ebuild b/app-text/wiki2beamer/wiki2beamer-0.9.5-r1.ebuild
new file mode 100644
index 000000000000..40614670ffab
--- /dev/null
+++ b/app-text/wiki2beamer/wiki2beamer-0.9.5-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit python-single-r1
+
+DESCRIPTION="Tool to produce LaTeX Beamer code from wiki-like input"
+
+HOMEPAGE="http://wiki2beamer.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
+
+LICENSE="|| ( GPL-2 GPL-3 ) FDL-1.3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+examples"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+src_install() {
+ if use examples; then
+ # Patch example Makefile
+ sed -e 's|../../code/wiki2beamer|wiki2beamer|' \
+ -i doc/example/Makefile \
+ || die
+
+ dodoc -r doc/example
+ fi
+
+ doman doc/man/${PN}.1
+ dodoc ChangeLog README
+
+ python_doscript code/${PN}
+}