summaryrefslogtreecommitdiff
path: root/app-text/webgen/webgen-1.7.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-04 07:58:30 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-04 07:58:30 +0000
commit5e0583283abb5e0f998830cea3f4f9785699b2ed (patch)
treec9999a88a0ae4409d0f85dc733d2b42181f94a53 /app-text/webgen/webgen-1.7.3.ebuild
parentfa3c4c282d03b85eb600bae6ec57b619004feb5a (diff)
gentoo auto-resync : 04:01:2024 - 07:58:30
Diffstat (limited to 'app-text/webgen/webgen-1.7.3.ebuild')
-rw-r--r--app-text/webgen/webgen-1.7.3.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/app-text/webgen/webgen-1.7.3.ebuild b/app-text/webgen/webgen-1.7.3.ebuild
new file mode 100644
index 000000000000..c630a650eedd
--- /dev/null
+++ b/app-text/webgen/webgen-1.7.3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_DOC="task"
+RUBY_FAKEGEM_DOCDIR="htmldoc/rdoc"
+RUBY_FAKEGEM_EXTRADOC="AUTHORS THANKS"
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A template-based static website generator"
+HOMEPAGE="https://webgen.gettalong.org"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="builder doc highlight markdown"
+
+ruby_add_bdepend "doc? ( dev-ruby/rdoc )
+ test? (
+ dev-ruby/minitest:5
+ dev-ruby/rdiscount
+ >=dev-ruby/sass-3.2:* )"
+
+ruby_add_rdepend ">=dev-ruby/cmdparse-3.0.1:3
+ >=dev-ruby/systemu-2.5 =dev-ruby/systemu-2*
+ >=dev-ruby/kramdown-2.3:2
+ >=dev-ruby/psych-5.1:5
+ builder? ( >=dev-ruby/builder-2.1.0:* )
+ highlight? ( >=dev-ruby/coderay-1.0 )
+ markdown? ( dev-ruby/maruku )"
+
+all_ruby_prepare() {
+ # Avoid a test fragile for sass version differences
+ sed -i -e '/test_static_call/,/^ end/ s:^:#:' test/webgen/content_processor/test_sass.rb || die
+ # Avoid a test with fragile whitespace tests
+ rm -f test/webgen/content_processor/test_haml.rb || die
+
+ # Avoid tests for rdoc since that requires an obsolete version
+ sed -i -e '/def test_create_nodes/askip' test/webgen/path_handler/test_api.rb || die
+
+ # Avoid tests for unpackaged dependencies
+ rm -f test/webgen/content_processor/test_{css_minify,tikz}.rb || die
+
+ # Avoid tests failing with newer Psych versions
+ rm -f test/test_documentation.rb || die
+
+ # Fix minitest deprecation
+ sed -i -e 's/MiniTest/Minitest/' $(find test -type f -print) || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/man1/webgen.1
+}