summaryrefslogtreecommitdiff
path: root/app-text/wdiff/wdiff-1.2.2-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-10 13:27:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-10 13:27:24 +0100
commit0d7aefa5885e7552b4c2221df9f54e5930696228 (patch)
treeb7f05f240bfd3bc81f87edba206e78a8dc1a664b /app-text/wdiff/wdiff-1.2.2-r2.ebuild
parent34d9839f7e484ac761071da50298470aa5ef5123 (diff)
gentoo auto-resync : 10:07:2022 - 13:27:24
Diffstat (limited to 'app-text/wdiff/wdiff-1.2.2-r2.ebuild')
-rw-r--r--app-text/wdiff/wdiff-1.2.2-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-text/wdiff/wdiff-1.2.2-r2.ebuild b/app-text/wdiff/wdiff-1.2.2-r2.ebuild
new file mode 100644
index 000000000000..4418e21d3f05
--- /dev/null
+++ b/app-text/wdiff/wdiff-1.2.2-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Create a diff disregarding formatting"
+HOMEPAGE="https://www.gnu.org/software/wdiff/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris"
+IUSE="experimental test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ sys-apps/diffutils
+ sys-apps/less
+ sys-libs/ncurses:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-apps/texinfo
+ test? ( app-misc/screen )
+"
+
+src_configure() {
+ econf $(use_enable experimental)
+}
+
+src_test() {
+ # The test suite hangs in the '3: use pager' test
+ # when an incompatible screenrc is found
+ touch tests/screenrc || die
+ export SYSSCREENRC=tests/screenrc SCREENRC=tests/screenrc
+
+ default
+}