summaryrefslogtreecommitdiff
path: root/app-text/vgrep
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
commit90c88731bd036e5698b281fbc0a5f3aa4c9983ac (patch)
tree83fc5facb6b12be510a37bc3d241cc63e965b13a /app-text/vgrep
parentfeb0daf81d888e9160f9f94502de09b66f2a63fd (diff)
gentoo resync : 29.06.2020
Diffstat (limited to 'app-text/vgrep')
-rw-r--r--app-text/vgrep/Manifest3
-rw-r--r--app-text/vgrep/metadata.xml12
-rw-r--r--app-text/vgrep/vgrep-2.3.1.ebuild33
3 files changed, 48 insertions, 0 deletions
diff --git a/app-text/vgrep/Manifest b/app-text/vgrep/Manifest
new file mode 100644
index 000000000000..8ff2f50aeda1
--- /dev/null
+++ b/app-text/vgrep/Manifest
@@ -0,0 +1,3 @@
+DIST vgrep-2.3.1.tar.gz 1149421 BLAKE2B c4c9a414bba5e509d57faa9ca6f6ce5cae1dbb001ff8b410ad54691ec6bf39f41c535fd25bdd5d93fdf89b4e4b49acf4dfa9a8956653e5c5e2ce39bd7da8d484 SHA512 0fa65151ae40f7fefc4e5b1af8e6ea332b50b1136849ec0902dd110786ca14204441e27c65a036b08fa56bf04a6325d8aa8ef2d4d02cdb0e0fe219896e24d694
+EBUILD vgrep-2.3.1.ebuild 656 BLAKE2B 8d1ec68257d10e042ec75ca12b8f8a0df43f7ecb92ae3be1dffed18cbb326e713b95e460b3c630919b40ec51af30dbe71f82e0f011381b2ba8ce754cffd7e45c SHA512 254a81ae86eed74e50457ebe1041eb526340c6f9075044a68853d802d7f2d724791790b5912db9eae76e3180046d0ef7f4aef253623eb8d0f0c43a20310ab5b8
+MISC metadata.xml 394 BLAKE2B 52d95eb8f47c5002203258b8077e0104423472b1f4bdae387fa8194b5056fd4986a9b795d0bbaa7939497ce45ff2ee0ca90e1c44ebeaf31b40725b36ddf1390a SHA512 9f44f00b50a654d27819e20172dc338d3dac8abcdac3933df88153156871612e1c414dcc5b0590795eb58c972302c3b54546b7dbbd539ca60737bcfa5a8989f3
diff --git a/app-text/vgrep/metadata.xml b/app-text/vgrep/metadata.xml
new file mode 100644
index 000000000000..4965843d0e80
--- /dev/null
+++ b/app-text/vgrep/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>whissi@gentoo.org</email>
+ <name>Thomas Deutschmann</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/vrothberg/vgrep/issues</bugs-to>
+ <remote-id type="github">vrothberg/vgrep</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/vgrep/vgrep-2.3.1.ebuild b/app-text/vgrep/vgrep-2.3.1.ebuild
new file mode 100644
index 000000000000..f50049ccd32f
--- /dev/null
+++ b/app-text/vgrep/vgrep-2.3.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit go-module
+
+DESCRIPTION="A pager for grep, git-grep and similar grep implementations"
+HOMEPAGE="https://github.com/vrothberg/vgrep"
+SRC_URI="https://github.com/vrothberg/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD GPL-3+ MIT MIT-with-advertising"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# Uses golangci-lint
+RESTRICT="test"
+
+DOCS=( README.md )
+
+# go binary
+QA_PRESTRIPPED="usr/bin/vgrep"
+
+src_compile() {
+ emake build
+}
+
+src_install() {
+ local prefix="${D}/usr"
+ mkdir -p "${prefix}"/bin || die
+
+ emake PREFIX="${prefix}" install
+}