summaryrefslogtreecommitdiff
path: root/app-text/vgrep/vgrep-2.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /app-text/vgrep/vgrep-2.6.0.ebuild
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'app-text/vgrep/vgrep-2.6.0.ebuild')
-rw-r--r--app-text/vgrep/vgrep-2.6.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-text/vgrep/vgrep-2.6.0.ebuild b/app-text/vgrep/vgrep-2.6.0.ebuild
new file mode 100644
index 000000000000..3ca9a3117ab5
--- /dev/null
+++ b/app-text/vgrep/vgrep-2.6.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit go-module
+
+DESCRIPTION="A pager for grep, git-grep and similar grep implementations"
+HOMEPAGE="https://github.com/vrothberg/vgrep"
+SRC_URI="https://github.com/vrothberg/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD GPL-3+ MIT MIT-with-advertising"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# golangci-lint is required to run tests which is not yet packaged
+RESTRICT="strip test"
+
+BDEPEND="dev-go/go-md2man"
+
+DOCS=( README.md )
+
+src_compile() {
+ emake build
+}
+
+src_install() {
+ emake PREFIX="${D}/usr" install
+ einstalldocs
+}