summaryrefslogtreecommitdiff
path: root/app-text/uudeview/uudeview-0.5.20-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/uudeview/uudeview-0.5.20-r2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/uudeview/uudeview-0.5.20-r2.ebuild')
-rw-r--r--app-text/uudeview/uudeview-0.5.20-r2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-text/uudeview/uudeview-0.5.20-r2.ebuild b/app-text/uudeview/uudeview-0.5.20-r2.ebuild
new file mode 100644
index 000000000000..17446a4e771f
--- /dev/null
+++ b/app-text/uudeview/uudeview-0.5.20-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils autotools
+
+DESCRIPTION="uu, xx, base64, binhex decoder"
+HOMEPAGE="http://www.fpx.de/fp/Software/UUDeview/"
+SRC_URI="http://www.fpx.de/fp/Software/UUDeview/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="tk"
+
+RDEPEND="tk? ( dev-lang/tk:0 )"
+DEPEND="${RDEPEND}"
+
+DOCS=( HISTORY INSTALL README )
+
+PATCHES=(
+ "${FILESDIR}/${P}-bugfixes.patch"
+ "${FILESDIR}/${P}-CVE-2004-2265.patch"
+ "${FILESDIR}/${P}-CVE-2008-2266.patch"
+ "${FILESDIR}/${P}-man.patch"
+ "${FILESDIR}/${P}-rename.patch"
+ "${FILESDIR}/${P}-makefile.patch"
+)
+
+src_prepare() {
+ epatch "${PATCHES[@]}"
+
+ mv configure.in configure.ac || die
+
+ epatch_user
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable tk tcl) \
+ $(use_enable tk)
+}