summaryrefslogtreecommitdiff
path: root/app-text/texi2html
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/texi2html
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/texi2html')
-rw-r--r--app-text/texi2html/Manifest3
-rw-r--r--app-text/texi2html/metadata.xml8
-rw-r--r--app-text/texi2html/texi2html-5.0-r1.ebuild56
3 files changed, 67 insertions, 0 deletions
diff --git a/app-text/texi2html/Manifest b/app-text/texi2html/Manifest
new file mode 100644
index 000000000000..c4498e81029c
--- /dev/null
+++ b/app-text/texi2html/Manifest
@@ -0,0 +1,3 @@
+DIST texi2html-5.0.tar.bz2 15397249 BLAKE2B 3e502d9424c2936a922488aab7a66140c0a8369253a5500beeebcea0942ffa7b97fb7021b23212264e110d4bdab4850f263269aacf61de23ac6e052dfcf10d67 SHA512 50afc2f1f8875d3e62a51cc0339bd4c4f058041f42a9fda9cd5b02960f0d5c72838e4f010702ba716dbd256946f64520ce1e5b86539b6f7b8b7ce24a43c98e9d
+EBUILD texi2html-5.0-r1.ebuild 1321 BLAKE2B b9c038b1a7317b6b2a74acc21414f0a687fdcc7688cf7e2cd30026e3f11641a78e06acd5fd5fcd1973a90d84aa13d65cafe29a48f0a9a1313bd84b70b2f2fb17 SHA512 587ef4af50303b8a1dd1bd4f41a79a23110a88081b61686322798cd6e78a03a68f46eca409779712d453599cb830bc24258963ec00d6a88d1224e70cf3f93e54
+MISC metadata.xml 245 BLAKE2B ee3a163cfe0a4bc59c0dfb46f9ddb580e2d259b4d0e33cb4e684eb9e6d4b901bf97c6edd891f3b75a613a782f1b89318d0ee3ec9bee4e34c4441d9e8f4267678 SHA512 1653777623e2c15e1ce13229e396723b2cc9c214983e0f8592de98c01a31badc6c38c6735ed44f937d145883b43fb6f049af3eddb9ff96b18c96ccf8f67dd690
diff --git a/app-text/texi2html/metadata.xml b/app-text/texi2html/metadata.xml
new file mode 100644
index 000000000000..13170c3184d8
--- /dev/null
+++ b/app-text/texi2html/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>tex@gentoo.org</email>
+ <name>Gentoo TeX Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/app-text/texi2html/texi2html-5.0-r1.ebuild b/app-text/texi2html/texi2html-5.0-r1.ebuild
new file mode 100644
index 000000000000..3c4b85e12fc2
--- /dev/null
+++ b/app-text/texi2html/texi2html-5.0-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit prefix
+
+DESCRIPTION="Perl script that converts Texinfo to HTML"
+HOMEPAGE="http://www.nongnu.org/texi2html/"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.bz2"
+
+LICENSE="CC-SA-1.0 FDL-1.3 GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="unicode"
+
+RDEPEND=">=dev-lang/perl-5.10.1
+ >=dev-perl/libintl-perl-1.200
+ unicode? (
+ dev-perl/Text-Unidecode
+ dev-perl/Unicode-EastAsianWidth
+ )"
+DEPEND="${RDEPEND}"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+RESTRICT="test" #411523
+
+src_prepare() {
+ # On FreeBSD this script is used instead of GNU install but it comes without
+ # executable pemissions... Fix it!
+ chmod +x install-sh || die
+
+ if use prefix; then
+ hprefixify $(find . -name '*.pl' | xargs)
+ fi
+}
+
+src_configure() {
+ local myconf
+ use unicode && myconf='--with-external-Unicode-EastAsianWidth'
+
+ econf \
+ --with-external-libintl-perl \
+ $(use_with unicode unidecode) \
+ ${myconf}
+}
+
+src_install() {
+ default
+ rm -f "${ED}"/usr/share/${PN}/images/{COPYING*,GPL,README}
+}
+
+pkg_preinst() {
+ rm -f "${EROOT}"/usr/bin/${PN}
+}