summaryrefslogtreecommitdiff
path: root/app-text/teckit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/teckit
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/teckit')
-rw-r--r--app-text/teckit/Manifest4
-rw-r--r--app-text/teckit/files/teckit-2.5.1-mixcflagscxxflags.patch16
-rw-r--r--app-text/teckit/metadata.xml11
-rw-r--r--app-text/teckit/teckit-2.5.6.ebuild42
4 files changed, 73 insertions, 0 deletions
diff --git a/app-text/teckit/Manifest b/app-text/teckit/Manifest
new file mode 100644
index 000000000000..561648f3ef2e
--- /dev/null
+++ b/app-text/teckit/Manifest
@@ -0,0 +1,4 @@
+AUX teckit-2.5.1-mixcflagscxxflags.patch 534 BLAKE2B 98c7ec0325821d6fc8ed4952cce4ec38233302c25e0b6e4157c357693c16ee756c553347cf70aa1381315e0bb1c721e3e423ec6855a5c80fd2a5a298eaeb62d2 SHA512 7b76d3ebc6ecba24a7cd6469b47b35245e73d5c02a32c67a6205434f8c4b73ab6f1a77d0f8cf95081c4b441e876a2d62a1c276f69171d4f9f4679ccccbfd1c87
+DIST teckit-2.5.6.tar.gz 2500800 BLAKE2B a41c51e80b558d9735be782ed655fe36ec673180e559a3063c3b78ece14e470e194740f2039863a6e7a12e006c2314c3b73eff5de4d289c8eca1b6c9744f1e0d SHA512 d3462dbf22658de85fd718c43229259c460730d907226435195742f1ab65accc4ec83f7b6cb32a0e99fa12ddb7f2b7b5f2598c8853636aa5b31c8592ed9b4745
+EBUILD teckit-2.5.6.ebuild 1143 BLAKE2B d2baeade44a8f6d86f546f6936f6d31643e7309d1df69fe38a0b054b32a845b68eadab935afd0bf8b255296c474ce12880ea1a740bb493d5d426f325aca54caa SHA512 90f8c074eb690fce1a80a3ad51dd29c2a39bfde540958cb7be05521e139ba3dbb0e6a2f1dffb363a9c13b10747c063b21b363d3519c4f8f8e43778c3f7b14973
+MISC metadata.xml 328 BLAKE2B 55a9af22d43fe5270c143f0bdd0fdaa5bf58665a47c6386b83611071a25c8e41e0116bd48c3b6ff051b51e28f9f0bbbb1d09a97939f03df5e367a352c99b6f09 SHA512 f4ee21269605eb831d9a6cbe639da9f2bf63aa14ffb69bf41b7fa4304e4680f5e11ff9efaf30b63cbe0f3708468af19c5412353dab4af8d9a49e6f845a2b7f67
diff --git a/app-text/teckit/files/teckit-2.5.1-mixcflagscxxflags.patch b/app-text/teckit/files/teckit-2.5.1-mixcflagscxxflags.patch
new file mode 100644
index 000000000000..5a290f45133b
--- /dev/null
+++ b/app-text/teckit/files/teckit-2.5.1-mixcflagscxxflags.patch
@@ -0,0 +1,16 @@
+No need to pass CFLAGS twice, esp. if they are used to feed g++
+Bug #338110
+
+Index: TECkit_2_5_1/configure.ac
+===================================================================
+--- TECkit_2_5_1.orig/configure.ac
++++ TECkit_2_5_1/configure.ac
+@@ -76,7 +76,7 @@ noexpat_CFLAGS="$CFLAGS"
+ noexpat_LIBS="$LIBS"
+ AC_CHECK_LIB(expat, XML_ExpatVersion)
+ AM_CONDITIONAL(SYSTEM_EXPAT, test x$ac_cv_lib_expat_XML_ExpatVersion = xyes)
+-expat_CFLAGS="$CFLAGS"
++expat_CFLAGS=""
+ expat_LIBS="$LIBS"
+ CFLAGS="$noexpat_CFLAGS"
+ LIBS="$noexpat_LIBS"
diff --git a/app-text/teckit/metadata.xml b/app-text/teckit/metadata.xml
new file mode 100644
index 000000000000..480b5571f79a
--- /dev/null
+++ b/app-text/teckit/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>tex@gentoo.org</email>
+ <name>Gentoo TeX Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">silnrsi/teckit</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/teckit/teckit-2.5.6.ebuild b/app-text/teckit/teckit-2.5.6.ebuild
new file mode 100644
index 000000000000..045beae1707b
--- /dev/null
+++ b/app-text/teckit/teckit-2.5.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="Text Encoding Conversion toolkit"
+HOMEPAGE="http://scripts.sil.org/cms/scripts/page.php?site_id=nrsi&cat_id=TECkit"
+SRC_URI="https://github.com/silnrsi/teckit/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( CPL-0.5 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+RDEPEND="sys-libs/zlib
+ dev-libs/expat"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-2.5.1-mixcflagscxxflags.patch"
+ rm -f configure
+ sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS README NEWS
+ find "${ED}" -name '*.la' -delete || die
+}
+
+src_test() {
+ cd "${S}/test"
+ chmod +x dotests.pl
+ ./dotests.pl || die "tests failed"
+}