summaryrefslogtreecommitdiff
path: root/app-text/teckit/teckit-2.5.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/teckit/teckit-2.5.6.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/teckit/teckit-2.5.6.ebuild')
-rw-r--r--app-text/teckit/teckit-2.5.6.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-text/teckit/teckit-2.5.6.ebuild b/app-text/teckit/teckit-2.5.6.ebuild
new file mode 100644
index 000000000000..607a5a9834f2
--- /dev/null
+++ b/app-text/teckit/teckit-2.5.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="Text Encoding Conversion toolkit"
+HOMEPAGE="http://scripts.sil.org/cms/scripts/page.php?site_id=nrsi&cat_id=TECkit"
+SRC_URI="https://github.com/silnrsi/teckit/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( CPL-0.5 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+RDEPEND="sys-libs/zlib
+ dev-libs/expat"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-2.5.1-mixcflagscxxflags.patch"
+ rm -f configure
+ sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS README NEWS
+ find "${ED}" -name '*.la' -delete || die
+}
+
+src_test() {
+ cd "${S}/test"
+ chmod +x dotests.pl
+ ./dotests.pl || die "tests failed"
+}