summaryrefslogtreecommitdiff
path: root/app-text/sword
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-23 07:00:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-23 07:00:28 +0100
commite23cdda4dbb0c83b9e682ab5e916085a35203da5 (patch)
tree5a4ac448a3b288b731c24d947e0ce52df3cab07b /app-text/sword
parent8187a741807f3e9a9e26304973cf18087dcf2560 (diff)
gentoo resync : 23.06.2018
Diffstat (limited to 'app-text/sword')
-rw-r--r--app-text/sword/Manifest2
-rw-r--r--app-text/sword/sword-1.8.0.ebuild84
2 files changed, 86 insertions, 0 deletions
diff --git a/app-text/sword/Manifest b/app-text/sword/Manifest
index 7c557710b8de..4c4556e39168 100644
--- a/app-text/sword/Manifest
+++ b/app-text/sword/Manifest
@@ -1,5 +1,7 @@
AUX sword-1.7.4-configure.patch 816 BLAKE2B 6b1dc70d5146178be9e2e650b6a46f9a64dfbab2edfddeea7c4f3825c00ccf1af7fe328b86be90c3730ecb928ae9fe1c4558f3a0bcb6acfba6a207a48c32b3f6 SHA512 b6209e3a01a3408ca7d338ada40f3e9e2db93167b74274f29ea4a790a22b21d9e871037eb71875ec6d84f14477a78944a9ef2296fb623dbedfdfd3a849e44186
AUX sword-1.7.4-gcc6.patch 626 BLAKE2B 69b56ed6152d07962d5941868925ac35825256e4db22cc435c7580694925694902eb6c322d143af7148ea4a60828e059409625e9415cbb5f8905d98b4a1d85c5 SHA512 8084f3ce8be27879a5b038c5c55ed6c0071e02c2f19ee390cdbc6eaf822fb5268c0f5f9450ba22dfc944b5a1d46f5e4feeebd81f3810532edc9f905921b95f04
DIST sword-1.7.4.tar.gz 2157882 BLAKE2B 7ed50430500ec428a125e24550a1f7d0437a0253cf4fabad4c8af452d2aa82c71c11e4a6c334ef1a95d82f14ce1cc092f3774210113e9668ba207875b3a11b20 SHA512 4c8b183e613367364439cc7a8a842012f75180fccc8eb775b9af2dc4c10f39c152261d35f0aadaaa91a11df36ab1a4057c2edc50ea4b0b3bb0ab0a847ff68f75
+DIST sword-1.8.0.tar.gz 2444386 BLAKE2B dd74ca409cdc3e4563ec5f0ed225556cfc3d1c89e63b41df8335b4abdd4f36b1423a2953a86105d2efe8d57c0e57065f74e74629309bab93f2a0222b9a8fcc86 SHA512 c45f3135255322a77e955297997db2529f31b397c42cc4b9474dc6ec8d329b2233b292078979de5fbf33cad4a1a607aabb66f86501072a729d68e9fc840c8c8e
EBUILD sword-1.7.4-r1.ebuild 1974 BLAKE2B cdccfbf2bc8cc2f6a22b1bf88a929faf3a6305f271956acf83f0e9d4383b02a6e74201bc0accb28becc05b5e979f4032dcd48d9addab74ca5563c0bcb4d008c4 SHA512 b9c272643badb68f6af83bdf7a50f070f3a0fa56ed21ecf9c1b1ae941e5bee671cc9674fc8fba3b6042bc111f19576fa3d731700b7a9c91fbc637558e74886f0
+EBUILD sword-1.8.0.ebuild 1924 BLAKE2B aeb08e11551a7a8e81acf4da0aa69530772a49334c75a14f74b63109c73d89115d4abc0e1c815a892182edbc907a3689e8387c2c045f3230763c71f7c39bfaa8 SHA512 7c880515213d6fb58091177351f799ea49d8633e7f3bd8da5e396555c456dc4796d3b8798b21c56ae8d44b4ebd5543bf2116786cce2065a651572431dbc54475
MISC metadata.xml 564 BLAKE2B b7ed0b7e3e245079c82d4ebcb446a1e864e0f72610ac9c60d98fbfc73c7d078f12ddb7d1650fbc3816ac292c8c6b122990a71b0e99056eb21bdb4f3a8dc8b3ec SHA512 74ff38bf540aa48eb0195c7999adcf1226ede7ca4a6848a45b73913011f95e2bb7d84e0ca0534d2ee2610efee78234a52ae69f507704bb0ec80e4876a5d4aadc
diff --git a/app-text/sword/sword-1.8.0.ebuild b/app-text/sword/sword-1.8.0.ebuild
new file mode 100644
index 000000000000..bb6ed4a2b108
--- /dev/null
+++ b/app-text/sword/sword-1.8.0.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit flag-o-matic
+
+DESCRIPTION="Library for Bible reading software"
+HOMEPAGE="http://www.crosswire.org/sword/"
+SRC_URI="http://www.crosswire.org/ftpmirror/pub/${PN}/source/v${PV%.*}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd ~ppc-macos"
+IUSE="clucene curl debug doc icu static-libs"
+
+RDEPEND="sys-libs/zlib
+ curl? ( net-misc/curl )
+ icu? ( dev-libs/icu:= )
+ clucene? ( dev-cpp/clucene )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+DOCS="AUTHORS CODINGSTYLE ChangeLog README"
+
+RESTRICT="test" #Restricting for now, see bug 313207
+
+src_prepare() {
+ sed -i \
+ -e '/FLAGS/s:-g3::' -e '/FLAGS/s:-O0::' \
+ -e '/FLAGS/s:-O2::' -e '/FLAGS/s:-O3::' \
+ configure || die
+
+ sed -i -e '/FLAGS/s:-Werror::' configure || die #408289
+ sed -i -e '/^#inc.*curl.*types/d' src/mgr/curl*.cpp || die #378055
+
+ cat <<-EOF > "${T}"/${PN}.conf
+ [Install]
+ DataPath=${EPREFIX}/usr/share/${PN}/
+ EOF
+ eapply "${FILESDIR}/${PN}-1.7.4-configure.patch"
+ eapply_user
+}
+
+src_configure() {
+ # TODO: Why is this here and can we remove it?
+ strip-flags
+
+ # bug 618776
+ append-cxxflags -std=c++14
+
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable debug) \
+ --with-zlib \
+ $(use_with icu) \
+ --with-conf \
+ $(use_with curl) \
+ $(use_with clucene)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
+
+ if use doc; then
+ rm -rf examples/.cvsignore
+ rm -rf examples/cmdline/.cvsignore
+ rm -rf examples/cmdline/.deps
+ cp -R samples examples "${ED}"/usr/share/doc/${PF}/
+ fi
+
+ insinto /etc
+ doins "${T}"/${PN}.conf
+}
+
+pkg_postinst() {
+ elog "Check out http://www.crosswire.org/sword/modules/"
+ elog "to download modules that you would like to use with SWORD."
+ elog "Follow module installation instructions found on"
+ elog "the web or in ${EROOT}/usr/share/doc/${PF}/"
+}