summaryrefslogtreecommitdiff
path: root/app-text/sloccount/sloccount-2.26-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/sloccount/sloccount-2.26-r3.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/sloccount/sloccount-2.26-r3.ebuild')
-rw-r--r--app-text/sloccount/sloccount-2.26-r3.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-text/sloccount/sloccount-2.26-r3.ebuild b/app-text/sloccount/sloccount-2.26-r3.ebuild
new file mode 100644
index 000000000000..0c1bc3de2f75
--- /dev/null
+++ b/app-text/sloccount/sloccount-2.26-r3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Tools for counting Source Lines of Code (SLOC) for a large number of languages"
+HOMEPAGE="http://www.dwheeler.com/sloccount/"
+SRC_URI="http://www.dwheeler.com/sloccount/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+RDEPEND="dev-lang/perl
+ >=sys-apps/sed-4
+ app-shells/bash"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libexec.patch
+ epatch "${FILESDIR}"/${P}-coreutils-tail-n-fix.patch
+ # support for .ebuild and #!/sbin/openrc-run:
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+
+ sed -i \
+ -e 's|^CC=gcc|CFLAGS+=|g' \
+ -e 's|$(CC)|& $(CFLAGS) $(LDFLAGS)|g' \
+ -e '/^DOC_DIR/ { s/-$(RPM_VERSION)//g }' \
+ -e '/^MYDOCS/ { s/[^ =]\+\.html//g }' \
+ makefile || die "sed makefile failed"
+
+ #fixed hard-codes libexec_dir in sloccount
+ sed -i "s|libexec_dir=|&\"${EPREFIX}\"|" sloccount || die
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_test() {
+ PATH+=":${S}"
+ emake test
+}
+
+src_install() {
+ emake PREFIX="${ED}/usr" DOC_DIR="${ED}/usr/share/doc/${PF}/" install
+ dohtml *html
+}