summaryrefslogtreecommitdiff
path: root/app-text/simple-fb2-reader/simple-fb2-reader-1.1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-08 09:04:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-08 09:04:53 +0100
commit73c318acdaf6f8309d68bd266051e6dd1f1bd787 (patch)
tree2878053f3e7faed19a1f82c733d3bd29df69991e /app-text/simple-fb2-reader/simple-fb2-reader-1.1.2.ebuild
parent2018227e9344edb9da15fc6a4a8298086cc2aa77 (diff)
gentoo resync : 08.06.2019
Diffstat (limited to 'app-text/simple-fb2-reader/simple-fb2-reader-1.1.2.ebuild')
-rw-r--r--app-text/simple-fb2-reader/simple-fb2-reader-1.1.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-text/simple-fb2-reader/simple-fb2-reader-1.1.2.ebuild b/app-text/simple-fb2-reader/simple-fb2-reader-1.1.2.ebuild
new file mode 100644
index 000000000000..c7d3c54be77d
--- /dev/null
+++ b/app-text/simple-fb2-reader/simple-fb2-reader-1.1.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils xdg-utils
+DESCRIPTION="A simple gtk3 reader for fb2 ebooks"
+HOMEPAGE="https://github.com/Cactus64k/simple-fb2-reader"
+SRC_URI="https://github.com/Cactus64k/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+RDEPEND="x11-libs/gtk+:3
+ dev-libs/libxml2
+ dev-libs/libzip
+ dev-db/sqlite"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ dev-util/pkgconfig"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ xdg_icon_cache_update
+}