summaryrefslogtreecommitdiff
path: root/app-text/sgrep/sgrep-1.94a.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/sgrep/sgrep-1.94a.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/sgrep/sgrep-1.94a.ebuild')
-rw-r--r--app-text/sgrep/sgrep-1.94a.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-text/sgrep/sgrep-1.94a.ebuild b/app-text/sgrep/sgrep-1.94a.ebuild
new file mode 100644
index 000000000000..2f7bae2fad40
--- /dev/null
+++ b/app-text/sgrep/sgrep-1.94a.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Use structural criteria to grep and index text, SGML, XML and HTML and filter"
+SRC_URI="ftp://ftp.cs.helsinki.fi/pub/Software/Local/Sgrep/${P}.tar.gz"
+HOMEPAGE="https://www.cs.helsinki.fi/u/jjaakkol/sgrep.html"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+src_prepare() {
+ default
+ sed -i -e "s:/usr/lib:/etc:g" sgrep.1 || die
+}
+
+src_configure() {
+ econf --datadir="${EPREFIX}"/etc
+}
+
+src_install() {
+ dobin sgrep
+ doman sgrep.1
+ dodoc AUTHORS ChangeLog NEWS README sample.sgreprc
+ insinto /etc
+ newins sample.sgreprc sgreprc
+}