summaryrefslogtreecommitdiff
path: root/app-text/searchmonkey/searchmonkey-0.8.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/searchmonkey/searchmonkey-0.8.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/searchmonkey/searchmonkey-0.8.1.ebuild')
-rw-r--r--app-text/searchmonkey/searchmonkey-0.8.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-text/searchmonkey/searchmonkey-0.8.1.ebuild b/app-text/searchmonkey/searchmonkey-0.8.1.ebuild
new file mode 100644
index 000000000000..e418a50adba1
--- /dev/null
+++ b/app-text/searchmonkey/searchmonkey-0.8.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Powerful text searches using regular expressions"
+HOMEPAGE="http://searchmonkey.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.6:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog INSTALL NEWS README
+ make_desktop_entry ${PN} ${PN} ${PN} "Utility;GTK"
+}