summaryrefslogtreecommitdiff
path: root/app-text/sary
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/sary
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/sary')
-rw-r--r--app-text/sary/Manifest3
-rw-r--r--app-text/sary/metadata.xml16
-rw-r--r--app-text/sary/sary-1.2.0-r1.ebuild41
3 files changed, 60 insertions, 0 deletions
diff --git a/app-text/sary/Manifest b/app-text/sary/Manifest
new file mode 100644
index 000000000000..5f71863507c9
--- /dev/null
+++ b/app-text/sary/Manifest
@@ -0,0 +1,3 @@
+DIST sary-1.2.0.tar.gz 393787 BLAKE2B bcfb393dbae4b5edd51b35a9bb542a1988a4293a321a72f9e3fbce48abbd034bcb96bac915fb330166c5d8adcb2f2b572e808b76508c0411521aef722422c074 SHA512 0eeae82a384970b4d96f7a0ca3929e74d17b8b3ebc61459ec9fc7172e61c3835ffe2de8aaab7ebd64f54be24d39f6734949ebc98758c28cec299b3bd25020632
+EBUILD sary-1.2.0-r1.ebuild 950 BLAKE2B d34edd5b708c68cc1494b7f41167446f6db9945ea239fcc0d87939e733d83b41b3632aeeea01b996b00a475a45006ad1e81045fee4ea8f2e49eedd3242f4f94d SHA512 74713f39515aec6da7df7664755243d28c339313c1de070824d2ef05a1deb50309ead443bdad9e490da891b92ed0daaa181f9cadb6337a38c9192c6772a7c83c
+MISC metadata.xml 614 BLAKE2B dbab63bef60f0c15430f90761b9660a90cc05561104ee73eb3848ba30fae5d8bd888e091afd6709d9796cc9fa087c350903e5c83077bd014fdfd9cb7d92dca3e SHA512 ef381dbe030d43e46f5b8aaf13c0783cb1a215bb2961793d75500712fd491983e2df30eb838eb504432d2cc844b7e064d0f96c0efd67d190295496b8cc082a15
diff --git a/app-text/sary/metadata.xml b/app-text/sary/metadata.xml
new file mode 100644
index 000000000000..c7ef82c510d5
--- /dev/null
+++ b/app-text/sary/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>cjk@gentoo.org</email>
+ <name>Cjk</name>
+ </maintainer>
+ <longdescription>Sary is a suffix array library and tools. It provides
+fast full-text search facilities for text files on the order of 10 to
+100 MB using a data structure called a suffix array. It can also
+search specific fields in a text file by assigning index points to
+those fields.</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">sary</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/sary/sary-1.2.0-r1.ebuild b/app-text/sary/sary-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..1155888702a7
--- /dev/null
+++ b/app-text/sary/sary-1.2.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+inherit autotools
+
+DESCRIPTION="Sary: suffix array library and tools"
+HOMEPAGE="http://sary.sourceforge.net/"
+SRC_URI="http://sary.sourceforge.net/${P}.tar.gz"
+IUSE="static-libs"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+SLOT="0"
+RESTRICT="test"
+
+RDEPEND="dev-libs/glib:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ echo "libsary_la_LIBADD = @GLIB_LIBS@" >> sary/Makefile.am || die
+ sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.in || die
+ eautoreconf
+}
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ docsdir="${EPREFIX}"/usr/share/doc/${PF}/html \
+ install
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ if ! use static-libs ; then
+ find "${ED}" -name '*.la' -delete
+ fi
+
+}