summaryrefslogtreecommitdiff
path: root/app-text/sablotron
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/sablotron
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/sablotron')
-rw-r--r--app-text/sablotron/Manifest4
-rw-r--r--app-text/sablotron/files/1.0.3-libsablot-expat.patch10
-rw-r--r--app-text/sablotron/metadata.xml5
-rw-r--r--app-text/sablotron/sablotron-1.0.3-r1.ebuild44
4 files changed, 63 insertions, 0 deletions
diff --git a/app-text/sablotron/Manifest b/app-text/sablotron/Manifest
new file mode 100644
index 000000000000..789082e576a1
--- /dev/null
+++ b/app-text/sablotron/Manifest
@@ -0,0 +1,4 @@
+AUX 1.0.3-libsablot-expat.patch 286 BLAKE2B 07728a2d174343133946519934a0b10aa0ea0d2c7e5ba73401b8c16ead71f059f78b24236bc96e17baf2467a5765ce0d82e67e97bb48225a9ba0fc5ac8a163d0 SHA512 29b7ae2798696439d3b181196677a7e7beacecac39abae631c73aff2d77e608bbf0088100953db78feb82cba37f89350da238cf8053e694c8ff0b3d8e8837040
+DIST Sablot-1.0.3.tar.gz 607597 BLAKE2B 429df09361d233b290e1179d5a3fbe7b421b834c23ff32d72466f007fd4ce19e810d68483b1b0314e943f2ff0f3713a3f28a357a71c69722883f5c85499cb582 SHA512 836c1a9d09317194333619461b0e5ea312277cadb6df5ae5ed327bdfee4090970bd3056ec0b3bd6aa8a3e3289af1bc5c1461c9fe15b53a944f1042190c485031
+EBUILD sablotron-1.0.3-r1.ebuild 1053 BLAKE2B e969fcfc506eaf71ca7534edb4e2bfdf7fec8c2813fb156511d61e99dcc860e0f5c3e0ae574dc50bb885cd8f03cc24530fa06f0179549815b0a6f98510d62225 SHA512 a3145154f2be9d371e1cbf33589f6da3723ef3106c38a6f278c3840043f58137bd7d072af0602c065665773ebf471a711fdc81dbadf400f8619aecd5e0aa21eb
+MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/app-text/sablotron/files/1.0.3-libsablot-expat.patch b/app-text/sablotron/files/1.0.3-libsablot-expat.patch
new file mode 100644
index 000000000000..328c9e906856
--- /dev/null
+++ b/app-text/sablotron/files/1.0.3-libsablot-expat.patch
@@ -0,0 +1,10 @@
+diff --git a/src/engine/Makefile.am b/src/engine/Makefile.am
+index abd2041..1307b1c 100644
+--- a/src/engine/Makefile.am
++++ b/src/engine/Makefile.am
+@@ -76,4 +76,5 @@ include_HEADERS = \
+ sabcfg.h
+
+ libsablot_la_LDFLAGS = -version-info 100:3:100
++libsablot_la_LIBADD = @EXPAT_LIBS@
+
diff --git a/app-text/sablotron/metadata.xml b/app-text/sablotron/metadata.xml
new file mode 100644
index 000000000000..6f49eba8f496
--- /dev/null
+++ b/app-text/sablotron/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+</pkgmetadata>
diff --git a/app-text/sablotron/sablotron-1.0.3-r1.ebuild b/app-text/sablotron/sablotron-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..622e9320de00
--- /dev/null
+++ b/app-text/sablotron/sablotron-1.0.3-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+MY_PN="Sablot"
+MY_P="${MY_PN}-${PV}"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="An XSLT Parser in C++"
+HOMEPAGE="http://www.gingerall.org/sablotron.html"
+SRC_URI="http://download-1.gingerall.cz/download/sablot/${MY_P}.tar.gz"
+
+# Sablotron can optionally be built under GPL, using MPL for now
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="perl"
+
+RDEPEND=">=dev-libs/expat-1.95.6-r1"
+DEPEND="${RDEPEND}
+ >=dev-perl/XML-Parser-2.3"
+
+PATCHES=( "${FILESDIR}/1.0.3-libsablot-expat.patch" )
+
+src_prepare() {
+ default
+ sed -i configure.in -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' || die
+ eautoreconf
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ $(use_enable perl perlconnect) \
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README README_JS RELEASE src/TODO
+}