summaryrefslogtreecommitdiff
path: root/app-text/sablotron/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-25 11:25:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-25 11:25:16 +0100
commit70a8e0f526762c28622fae5f944f8f59f9abf728 (patch)
treea58f1b704c29cff0ad8201d20ebbf7a11018f88f /app-text/sablotron/files
parent4eda0fe5576868e6c7f97b51aa1c279ff8cd320c (diff)
gentoo auto-resync : 25:09:2023 - 11:25:16
Diffstat (limited to 'app-text/sablotron/files')
-rw-r--r--app-text/sablotron/files/sablotron-1.0.3-cxx11.patch (renamed from app-text/sablotron/files/1.0.3-cxx11.patch)0
-rw-r--r--app-text/sablotron/files/sablotron-1.0.3-drop-register-keyword.patch14
-rw-r--r--app-text/sablotron/files/sablotron-1.0.3-libsablot-expat.patch (renamed from app-text/sablotron/files/1.0.3-libsablot-expat.patch)4
3 files changed, 16 insertions, 2 deletions
diff --git a/app-text/sablotron/files/1.0.3-cxx11.patch b/app-text/sablotron/files/sablotron-1.0.3-cxx11.patch
index edc1e3141d94..edc1e3141d94 100644
--- a/app-text/sablotron/files/1.0.3-cxx11.patch
+++ b/app-text/sablotron/files/sablotron-1.0.3-cxx11.patch
diff --git a/app-text/sablotron/files/sablotron-1.0.3-drop-register-keyword.patch b/app-text/sablotron/files/sablotron-1.0.3-drop-register-keyword.patch
new file mode 100644
index 000000000000..3dcf8c881efa
--- /dev/null
+++ b/app-text/sablotron/files/sablotron-1.0.3-drop-register-keyword.patch
@@ -0,0 +1,14 @@
+Bug: https://bugs.gentoo.org/894710
+--- a/src/engine/hash.cpp
++++ b/src/engine/hash.cpp
+@@ -305,8 +305,8 @@ void HashTable::report(Sit S, MsgType type, MsgCode code, const Str& arg1, const
+
+ oolong hash(const Str& key)
+ {
+- register oolong a, b, c, len;
+- register const char *k = (const char*) key;
++ oolong a, b, c, len;
++ const char *k = (const char*) key;
+
+ /* Set up the internal state */
+ len = key.length();
diff --git a/app-text/sablotron/files/1.0.3-libsablot-expat.patch b/app-text/sablotron/files/sablotron-1.0.3-libsablot-expat.patch
index e4f6c3fdfab3..614a6d7ffe24 100644
--- a/app-text/sablotron/files/1.0.3-libsablot-expat.patch
+++ b/app-text/sablotron/files/sablotron-1.0.3-libsablot-expat.patch
@@ -2,7 +2,7 @@
+++ b/src/engine/Makefile.am
@@ -76,4 +76,5 @@ include_HEADERS = \
sabcfg.h
-
+
libsablot_la_LDFLAGS = -version-info 100:3:100
+libsablot_la_LIBADD = @EXPAT_LIBS@
-
+