summaryrefslogtreecommitdiff
path: root/app-text/rtf2html/rtf2html-0.2.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/rtf2html/rtf2html-0.2.0-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/rtf2html/rtf2html-0.2.0-r1.ebuild')
-rw-r--r--app-text/rtf2html/rtf2html-0.2.0-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-text/rtf2html/rtf2html-0.2.0-r1.ebuild b/app-text/rtf2html/rtf2html-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..d5f0c353c4c1
--- /dev/null
+++ b/app-text/rtf2html/rtf2html-0.2.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4"
+
+inherit base flag-o-matic
+
+DESCRIPTION="RTF to HTML converter"
+HOMEPAGE="http://rtf2html.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rtf2html/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+DOCS=( ChangeLog README )
+
+PATCHES=( "${FILESDIR}/${P}-gcc43.patch" )
+
+src_prepare() {
+ # CFLAGS are incorrectly parsed, so handle this here
+ sed -i -e '/CFLAGS=$(echo $CFLAGS/d' configure || die 'sed on configure failed'
+ use !debug && filter-flags "-g*"
+
+ base_src_prepare
+}
+
+src_configure() {
+ econf $(use_enable debug)
+}