summaryrefslogtreecommitdiff
path: root/app-text/ronn-ng
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /app-text/ronn-ng
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'app-text/ronn-ng')
-rw-r--r--app-text/ronn-ng/Manifest3
-rw-r--r--app-text/ronn-ng/ronn-ng-0.9.1-r1.ebuild52
-rw-r--r--app-text/ronn-ng/ronn-ng-0.9.1.ebuild2
3 files changed, 55 insertions, 2 deletions
diff --git a/app-text/ronn-ng/Manifest b/app-text/ronn-ng/Manifest
index 4f4b324eb4df..86fcb836f71b 100644
--- a/app-text/ronn-ng/Manifest
+++ b/app-text/ronn-ng/Manifest
@@ -1,3 +1,4 @@
DIST ronn-ng-0.9.1.gem 69120 BLAKE2B 9da30156104ef448c458199ee33fb5369f7d97c7bbeac8072567127b964456a34226bcc15f72d6f2875f524175d31ec9652a282b369e818748790cd07f290786 SHA512 5ad7dc426d9bc77bca86fbb06775a3b19f1b8d79f5a4331d117e9fa394e7a9c3b0440b70b993672d77a24f56f5da3ebd0e41a5183f4330707b7ddb83c9108bdf
-EBUILD ronn-ng-0.9.1.ebuild 845 BLAKE2B 672a55a4477766ff9f0be7f14be73177a662f1be85413d5cc248af76d2279dbb7f0e602f19a6e212b27f8750e780c7afcca5b8b57e8b0bd195d96901c2733607 SHA512 b8e69d1f37e88d6f8d5aa77609db3a515da19d79c47c846087cd63b67863e6c7bdbd63ebdc59ffb521e3dbeecd4b1f3490c4270782d21fb6385d7be256a8caf8
+EBUILD ronn-ng-0.9.1-r1.ebuild 1017 BLAKE2B 6f9271362d8000e7a6cb7a97de947758e9a134b3f20d6c4e7aad011d0a83efa54534465d94f02fe11fae3c8c2aec633df90a856d63de98ff770bbe491cfd8225 SHA512 724a4c53fb5e74ee5633133a33bf984f43fab69e4b369d75819d01c9a8004cfd2bdf878784ca5e46016f81035f6b22d496797b8edbcc136534ef510027f1ce94
+EBUILD ronn-ng-0.9.1.ebuild 852 BLAKE2B 3c22d8d513af265b6a326b51a639bce5c1b3d09d42eb737198f42826eb89849a9a2dd108d07f2aca4f9a09a398b66efa088e8a8be165ec3575b5ba5047eae12b SHA512 61f5761f3080b120e353d5f4a025783ba51fade9739af437b392331ad626e02c37d505c854a928ae9d685653bcec9cdf78317cd2e6eb47bcdb4193fcde352864
MISC metadata.xml 342 BLAKE2B 71ab5a2d2a9e2d20165f54c1cf79f483768c3637cc87a32acf80708d79b3be9d24408a330ed23ad837848933b0a40f1165f60d7b7e08146a28088a4d9d558630 SHA512 92e6778f8a2f44a81dfdbbd6699ce2186cc48b801f5c462c99b4bc35f79806ff154d72bec2916d79dc7435c1a9b75f2bf3842b7dba2b132335afc38d00d22780
diff --git a/app-text/ronn-ng/ronn-ng-0.9.1-r1.ebuild b/app-text/ronn-ng/ronn-ng-0.9.1-r1.ebuild
new file mode 100644
index 000000000000..421aa12c568d
--- /dev/null
+++ b/app-text/ronn-ng/ronn-ng-0.9.1-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="AUTHORS CHANGES README.md"
+RUBY_FAKEGEM_GEMSPEC="ronn-ng.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Builds manuals in HTML and Unix man page format from Markdown"
+HOMEPAGE="https://github.com/apjanke/ronn-ng"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64"
+
+IUSE=""
+
+RDEPEND+="!app-text/ronn"
+
+DEPS="
+ >=dev-ruby/kramdown-2.1:2
+ >=dev-ruby/nokogiri-1.9.0:0
+"
+
+ruby_add_rdepend "
+ =dev-ruby/mustache-1*
+ ${DEPS}
+"
+
+ruby_add_bdepend "${DEPS}"
+
+all_ruby_prepare() {
+ sed -i -e '/mustache/ s/0.7/1.0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_prepare() {
+ # Make sure that we always use the right interpreter during tests.
+ sed -i -e "/output/ s:ronn:${RUBY} bin/ronn:" test/test_ronn.rb
+}
+
+all_ruby_compile() {
+ PATH="${S}/bin:${PATH}" rake man || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/ronn.1 man/ronn-format.7
+}
diff --git a/app-text/ronn-ng/ronn-ng-0.9.1.ebuild b/app-text/ronn-ng/ronn-ng-0.9.1.ebuild
index c35f4ad46bfc..4858edf7a04f 100644
--- a/app-text/ronn-ng/ronn-ng-0.9.1.ebuild
+++ b/app-text/ronn-ng/ronn-ng-0.9.1.ebuild
@@ -13,7 +13,7 @@ HOMEPAGE="https://github.com/apjanke/ronn-ng"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc"
IUSE=""