summaryrefslogtreecommitdiff
path: root/app-text/rman/rman-3.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/rman/rman-3.2-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/rman/rman-3.2-r1.ebuild')
-rw-r--r--app-text/rman/rman-3.2-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-text/rman/rman-3.2-r1.ebuild b/app-text/rman/rman-3.2-r1.ebuild
new file mode 100644
index 000000000000..ab6d881923bd
--- /dev/null
+++ b/app-text/rman/rman-3.2-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="PolyGlotMan man page translator AKA RosettaMan"
+HOMEPAGE="https://sourceforge.net/projects/polyglotman/"
+SRC_URI="mirror://sourceforge/polyglotman/${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RESTRICT="test"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gentoo.diff \
+ "${FILESDIR}"/${P}-ldflags.patch \
+ "${FILESDIR}"/${P}-format-security.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+}