summaryrefslogtreecommitdiff
path: root/app-text/rman/rman-3.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
commit129160ec854dca4c3fedb5bcfbcb56930371da0f (patch)
tree53bf797418ac5e9b99c41ca0382c87b82421e5de /app-text/rman/rman-3.2-r1.ebuild
parent441d1370330332b7d78f238d2f5e13f7aed5e4e0 (diff)
gentoo new year resync : 01.01.2021
Diffstat (limited to 'app-text/rman/rman-3.2-r1.ebuild')
-rw-r--r--app-text/rman/rman-3.2-r1.ebuild18
1 files changed, 8 insertions, 10 deletions
diff --git a/app-text/rman/rman-3.2-r1.ebuild b/app-text/rman/rman-3.2-r1.ebuild
index d57e0cb0ab0d..486e973975b8 100644
--- a/app-text/rman/rman-3.2-r1.ebuild
+++ b/app-text/rman/rman-3.2-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="PolyGlotMan man page translator AKA RosettaMan"
HOMEPAGE="https://sourceforge.net/projects/polyglotman/"
@@ -11,17 +11,15 @@ SRC_URI="mirror://sourceforge/polyglotman/${P}.tar.gz"
LICENSE="Artistic"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
RESTRICT="test"
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-gentoo.diff \
- "${FILESDIR}"/${P}-ldflags.patch \
- "${FILESDIR}"/${P}-format-security.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-ldflags.patch
+ "${FILESDIR}"/${P}-format-security.patch
+)
src_compile() {
emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"