summaryrefslogtreecommitdiff
path: root/app-text/refbase
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/refbase
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/refbase')
-rw-r--r--app-text/refbase/Manifest4
-rw-r--r--app-text/refbase/files/postinstall-en.txt22
-rw-r--r--app-text/refbase/metadata.xml11
-rw-r--r--app-text/refbase/refbase-0.9.5.ebuild39
4 files changed, 76 insertions, 0 deletions
diff --git a/app-text/refbase/Manifest b/app-text/refbase/Manifest
new file mode 100644
index 000000000000..fbebeb59fdfc
--- /dev/null
+++ b/app-text/refbase/Manifest
@@ -0,0 +1,4 @@
+AUX postinstall-en.txt 837 BLAKE2B 306f387521e1a4004434e5eba01b1254d6c893515ab0164f96f1bf26c07dbb9d8216d0a2a59173096637f9279d23128d123ae21fe1c8c86c07d7f3dd8d069a30 SHA512 fab28207a5d3bff1c8cb499ced404d5ecf2dfcd27493c0ba8b4cedd14518a0d2fdee16e61c28c6d14daa486de80ef33725cc66b48f4fe1ec9e150e5b037f9f3b
+DIST refbase-0.9.5.tar.gz 1395726 BLAKE2B d39b2ac6dc30e068e1f0f4ba22ca03bc4741c337a32a6e47675bd43d135c018018d2f7097ca8d0e21f72f3dbe51cdd111ba8b9cc855cabb6d3855a52e48625e9 SHA512 68022eee0c15a4e733a8eef8cd5ca15d6e29a4f3559539657c4a38733a4338b51ef4b716cfd964bdd5eb94dda3c7f012b6e01deb59879f3dbfd79d4d8ce11305
+EBUILD refbase-0.9.5.ebuild 904 BLAKE2B f6f0d2db8ccdaf0071caf6cc60e89424e3f4c1d2923668c73e6d1d43c45995ceda51b8c795ec1d63bfe29bb879254a73b09ae4bb03f6d9d0ff1ed45dbb8b2a5a SHA512 42234f423b8e9c3a6f8d3c878d7974d7f672689cf9a6fa61d01978296d6faada55c4c5fc66c1338384ab7481128f19fe01b6cce8d2b9bbd910b6071fd94f4d4b
+MISC metadata.xml 330 BLAKE2B 9e35fe6ced389ecb38ec836735c1d1482efcc1c606f438f433a34543a726d317d903beb94e3fc4c24b6297f4e209e7f8a02bbf046d34fbf3b4fa2813b4c12e89 SHA512 0fbcf620763f7e60e102335842267a1b934695c96b50055e5d338b5504592990c8817afe416cc3b48f9da72aa3365b83ec448165d07446c20fcd4bdd6e5ddb77
diff --git a/app-text/refbase/files/postinstall-en.txt b/app-text/refbase/files/postinstall-en.txt
new file mode 100644
index 000000000000..1b28143032f9
--- /dev/null
+++ b/app-text/refbase/files/postinstall-en.txt
@@ -0,0 +1,22 @@
+You are almost done!
+
+ 1. Restart your webserver
+
+ 2. Open the file '${MY_INSTALLDIR}/initialize/db.inc.php'
+ in a text editor and edit the values of the variables '\$databaseName',
+ '\$username' and '\$password' to fit your needs.
+ (Note that you'll be able to use the refbase package without modifying
+ these variables, but we highly recommend not to use the default
+ values!)
+
+ 3. Now, open a web browser and access the 'install.php' script by typing:
+
+ <http://${VHOST_HOSTNAME}/${VHOST_APPDIR}/install.php>
+
+ This should bring up the install form. Edit the contents of all text
+ entry fields to match your server setup and supply the MySQL admin
+ password, then click the 'Install' button to install the database.
+
+ 4. For further instructions, see /usr/share/doc/refbase-0.8.0/INSTALL.gz
+
+ Enjoy!
diff --git a/app-text/refbase/metadata.xml b/app-text/refbase/metadata.xml
new file mode 100644
index 000000000000..4652275b5605
--- /dev/null
+++ b/app-text/refbase/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">refbase</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/refbase/refbase-0.9.5.ebuild b/app-text/refbase/refbase-0.9.5.ebuild
new file mode 100644
index 000000000000..f2828b542eed
--- /dev/null
+++ b/app-text/refbase/refbase-0.9.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="2"
+inherit depend.apache webapp
+
+DESCRIPTION="Web-based solution for managing scientific literature, references and citations"
+HOMEPAGE="http://www.refbase.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+DEPEND="|| ( <dev-lang/php-5.3[pcre] >=dev-lang/php-5.3 )
+ dev-lang/php[mysql,session]
+ app-admin/webapp-config
+ app-text/bibutils"
+RDEPEND="${DEPEND}"
+
+need_apache
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install () {
+ webapp_src_preinst
+
+ DOCS="AUTHORS BUGS ChangeLog NEWS README TODO UPDATE"
+ dodoc ${DOCS}
+ # Don't install docs to webroot
+ rm -f ${DOCS} COPYING INSTALL
+
+ cp -R * "${D}"${MY_HTDOCSDIR}
+
+ webapp_configfile ${MY_HTDOCSDIR}/initialize
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}